Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I already installed mozplugger

sudo apt-get install mozplugger

Then I changed the pdf part of /etc/mozpluggerrc into the following:

application/pdf:pdf:PDF file
application/x-pdf:pdf:PDF file
text/pdf:pdf:PDF file
text/x-pdf:pdf:PDF file
    repeat noisy swallow(evince) fill: evince "$file"
    ACROREAD()
    repeat noisy swallow(kpdf) fill: kpdf "$file"
    repeat noisy swallow(Xpdf) fill: xpdf -g +9000+9000 "$file"
    repeat noisy swallow(okular) fill: okular "$file"
    GV()
    repeat noisy fill exits: evince "$file"

Of course I setted the application settings for pdf to Mozplugger.

Sometimes it works but mostly it dosn't. I don't know why. What do I have to do?

share|improve this question
add comment

2 Answers 2

up vote 5 down vote accepted

Firefox 15 has a pdf reader integrated with it, it is disabled by default, type about:config, search for "pdfjs.disabled" and set it to "false" double click it. Then go to edit preferences then go to applications search for pdf extension then select to open within firefox that should work for you.

share|improve this answer
    
Thank you very much! –  kikeriki Sep 4 '12 at 9:57
    
Sorry, there's a problem, sometimes I see the message: "The PDF document will not be displayed correctly eventually". So this is not so bad but I wouldn't have this problem when I used evince so a solution with evince would be better. –  kikeriki Sep 4 '12 at 10:24
    
I have check on this and the document seems to be viewed the same in evince as it is in the native pdf in firefox I believe that this is an issue that will be worked out in the next release of firefox. –  rstreeter78 Sep 4 '12 at 15:27
    
OK, thank you for your help! –  kikeriki Sep 4 '12 at 18:11
    
You're welcome, I hope that works for you. –  rstreeter78 Sep 4 '12 at 19:52
add comment

The accepted answer is dated. The PDF viewer in Firefox is now enabled by default.

On the other hand, Mozplugger still doesn't reliably enable Firefox show PDFs using Evince. I would particularly like that because it would permit substituting Windows-only fonts like Century Gothic with free (and available) ones like URW Gothic L by means of fontconfig.

Oh well. My workaround when a document appears less than optimally in Firefox's PDF viewer is to press the download icon and choose "Open with: Document Viewer (default)".

My version numbers: Ubuntu 13.10, Firefox 26, Mozplugger 1.14, Evince 3.10.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.