Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently purchased an ASUS N56VZ-ES71 laptop which came with Windows 7 Home Premium installed on it. I wish to dual boot Windows 7 and Ubuntu 12.04 on it. I shrank the hard drive partitions to leave about 150 GB unallocated for Ubuntu 12.04. When I boot the Live CD of Ubuntu and attempt to install, the installer does not recognize any other operating systems. Through reading a few questions, I have found that this is due to a GPT partitioning table that Windows uses.

I ran boot-repair as per other threads' suggestions. This was my output: http://paste.ubuntu.com/1176988/

I suppose my question is: how do I proceed in order to get the installer to recognize Windows, so that I don't have to erase the current partition table and can get a safe install?

Thanks in advance.

share|improve this question
    
Not really a good solution for you, but on my machine I found that whenever I installed Windows with UEFI Boot enabled in the bios, Ubuntu and gparted could not recognize the partitions. I had to disable UEFI Boot, reinstall Windows, then reenable UEFI Boot and install Ubuntu. –  csauve Oct 13 '12 at 1:44

5 Answers 5

You can manually specify the drives you want to use. When you install click on "partition Manually" or something in that context.

Then select your unallocated space, allocate space for the ubuntu partition and the swap partition.

I had the same problem too. :)

share|improve this answer
    
When I go into the manual partition menu, it shows my entire hard drive as free space. I'm afraid to write over the existing Windows partitions. Are you sure this is the way to do it? There's no choice to just select the unallocated space. –  trainofk Sep 4 '12 at 3:34

The Ubuntu tools cannot detect Windows because your partitioning has problems. For example, parted returns Error: Unable to satisfy all constraints on the partition.

The easiest way to fix this is:

  1. Backup your documents on an external disk (or DVDs..)

  2. Make sure you have a Windows DVD (burn one if you haven't)

  3. Via Gparted, format the entire disk (try to avoid GPT partitioning, use MsDos partition table). Create:

    • a NTFS partition (~50GB, where Windows will be reinstalled) at the start of the disk, put a boot flag on it.
    • a EXT4 partition (~20GB, where Ubuntu will be installed).
    • a SWAP partition (size of your RAM, ~5GB if you don't know, will be used by Ubuntu)
    • leave the end of the disk(~425GB) for data.
  4. Install Windows

  5. Install Ubuntu

share|improve this answer

First, GPT is not, in and of itself, the problem. The error you report (no partitions appearing in the installer) is indicative of a partition table problem. It's a long-standing bug of libparted (which the installer uses) that broken partition tables show as if they were blank disks. GPT is supported by libparted, though, and Ubuntu will install to GPT disks.

The key is this:

/dev/sda1 ends after the last sector of /dev/sda

This error message refers to the GPT's protective MBR, which is a "fake" MBR partition table that exists just to keep GPT-unaware utilities from using the disk. Your protective MBR contains a protective 0xEE partition that's too big. This really doesn't matter, but it's triggering libparted's "broken partition table" bug.

The solution is to fix the protective MBR. This is easily done using gdisk or sgdisk, which are part of the gdisk package in Ubuntu; however, I'm not sure if that package is installable in a live CD. Therefore, I'll tell you how to do this from an emergency disk:

  1. Download Parted Magic and burn it to CD.
  2. Boot Parted Magic.
  3. Launch a terminal window (the icon of a monitor on the bottom of the screen).
  4. Type gdisk /dev/sda to launch gdisk. You should see some startup messages and a prompt that reads Command (? for help):.
  5. Type p in gdisk to view your partition table and verify that everything looks OK. If you see weird partitions, exit by typing q.
  6. Type x to get to the experts' menu. The prompt should change to read Expert command (? for help):.
  7. Type n. This generates a fresh protective MBR. The program will respond merely by displaying a new prompt.
  8. Type w to save your changes. The program will warn you it will overwrite your old partitions and prompt you for confirmation. Respond y.
  9. Reboot and try installing again. It should now work fine.

One caveat: Your computer is booting Windows in EFI mode, so you should also install Ubuntu in EFI mode. This is sometimes trouble-prone. I recommend backing up your EFI System Partition (ESP; /dev/sda1) while you're in Parted Magic or by using the Ubuntu installer. If you have problems after installing, you may need to install a new boot loader. See my EFI Boot Loaders for Linux page for details.

share|improve this answer

Go through this link Ubuntu does not detect drive partitions

Hope it may help...

share|improve this answer

I had same problem on a computer that had installed windows 8. Looks like a problem with GPT traces left on the disc. I used systemrescuecd to execute this command:

fixparts /dev/sda

Delete the GPT info and write the partitin (using W) reboot and I was able to execute ubuntu on dual boot. I hope that it works for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.