Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to run 12.04 on my Acer Aspire 5732z. I know from research that these computers have issues with the backlight on Ubuntu. So I tried a couple of solutions:

  1. The sudo lightdm restart method. I get no change at all.

  2. The sudo setpci -s 00:02.0 F4.B=30 method.

    This so far has been the most effective. I first tried it in the F1 console, right away I get the screen back, problem is going back to the desktop it goes back to being black. So I tried it from a terminal window and it works as well but as soon as I unplug my external monitor the screen turns black again and doesn't come back. If I plug the monitor back in the screen stays black and the only thing I see is the mouse pointer. From here I go back into console (which I am able to see) and reboot from there.

  3. The sudo sed -i 's/GRUB_CMDLINE_LINUX=""/GRUB_CMDLINE_LINUX="acpi_osi=Linux"/g /etc/default/grub method.

    This one I got no instant change and after reboot still no change.

I'm open to pretty much any suggestions you may have.

EDIT: ok well I figured it out (more or less) I got it working the only problem is that when I used an external monitor the screen goes back black and I have to use the command again. But other than that got it working what I had to do was simply put the command into rc.local. I figure what I have to do to fix my external monitor problem is find the file that is executed when the screen state changes (monitor being plugged, screen turning on etc) and add the command into there.

There is also another strange problem, my screen brightness is inverted i.e. when I put the brightness setting up the screen gets darker and vis versa. This is only a minor annoyance that I can live with but if anyone knows a fix feel free to share. Looking forward to discussing with you all around the forum.

share|improve this question
add comment

1 Answer 1

Open up the terminal and type

sudo gedit /etc/default/grub

Find the below line

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash"

Replace the line with below mentioned line

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux acpi_backlight=vendor"

Save the changes and close the editor then come back to the terminal and enter the below command to update the grub configuration

sudo update-grub

Just reboot the machine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.