Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed the new version of Ubuntu (12.04) and nautilus seems to hide some file extension.

For example in my .local/application, the .desktop extension are not displayed. How to display the true name of files?

share|improve this question
    
Do your *.desktop files have names starting with . (like ".foo.desktop")? –  Keith Thompson Sep 4 '12 at 2:36
    
So you want to show the .desktop part of the Desktop files. Something like minecraft to minecraft.desktop (without hiding the .desktop part). If so then it is a good question. –  Luis Alvarado Sep 8 '12 at 22:35
    
I don't think any of the 3 current answers actually answer this question. nautilus is a file browser. It should be possible to see the actual names of the files it is browsing without having to change those files! –  Whippy Aug 1 '13 at 1:54

3 Answers 3

In the preferences you can set nautilus to show hidden files.

You can also optionally turn it off and on for the sessions life span by clicking Ctrl+H

Let me know if that answered your question.

share|improve this answer

Nautilus considers all .fileName to be hidden files (files starting with a dot character). Hit ctrl+h as suggested to show these files.

share|improve this answer
    
But not all .desktop files have names starting with . -- and on my system, most of them don't. –  Keith Thompson Sep 4 '12 at 2:35

Those are not hidden files, they are "desktop" files. I don't know to show real names of desktop files in a general manner but simply changing them to non-executable does what you want.

So to do this for each file, right click the file and follow the steps:

-> properties -> permissions -> Uncheck: Allow executing file as program

Via terminal:

chmod -x /where/is/this/desktop/file.desktop

But, if you do so, you can not execute the application using this .desktop file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.