Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a ton of trouble getting Suspend to work with my laptop. I want to start using Ubuntu but this is a pretty important aspect since I take my laptop with me everywhere. Anyways, I wanted to narrow down the possible problem with my laptop.

What happens is that when I suspend my computer, within seconds, it just boots back up. I have changed /proc/acpi/wakeup to where everything is disabled but that did nothing.

Is there a way where I can disable every feature from waking up the laptop except the power button?

share|improve this question
    
Have you looked at your BIOS? –  Mitch Sep 3 '12 at 19:05
    
Ya. The only thing that BIOS gives an option on is the ability to Enable/Disable USB Wake activity... which I disabled. –  user1399195 Sep 3 '12 at 19:13
    
You may have a glitching touchpad. Have you tried disabling it before suspending? –  sienile Sep 10 '12 at 16:03
    
Ya I've tried disabling the touchpad through bios with no results. –  user1399195 Sep 10 '12 at 19:14
    
It would be useful if you can inform us what kind of laptop make/model it is then we can see if this is a known issue for that hardware and/or we can figured out any workarounds or fixes. –  Colin Ian King Nov 27 '12 at 16:53

1 Answer 1

How do you suspend? Close the lid? Choose 'Suspend' from the shutdown menu? Call pm-suspend?

Have you verified the laptop actually ever properly went into suspend? Easiest indication is the slowly flashing power LED.

The starting point for debugging is to check dmesg, /var/log/syslog and /var/log/pm-suspend.log.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.