Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install ZTE's software for mobile broadband but it got error while installing itself.

Now I was ok with the network-manager which itself detects my USB modem. But, everytime while installing or removing or updating, I'm seeing this.

Actually here, I'm trying to remove crossplatformui which is part of ZTE: software:

sudo apt-get --purge remove crossplatformui
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
 crossplatformui
 0 upgraded, 0 newly installed, 1 to remove and 2 not upgraded.
 1 not fully installed or removed.
 After this operation, 0 B of additional disk space will be used.
 Do you want to continue [Y/n]? y
 (Reading database ... 480896 files and directories currently installed.)
 Removing crossplatformui ...
 ztemtvcdromd: no process found
 dpkg: error processing crossplatformui (--remove):
   subprocess installed post-removal script returned error exit status 1
No apport report written because MaxReports is reached already
Errors were encountered while processing:
crossplatformui
E: Sub-process /usr/bin/dpkg returned an error code (1)

Can anyone help me how to remove that crossplatform?

And can anyone give me a simple idea to auto reconnect my USB modem to Internet?

share|improve this question
    
try sudo dpkg -P crossplatformui for more info –  kubahaha Sep 3 '12 at 17:44
    
it shows same thing as above i said –  sarathprasath Sep 4 '12 at 2:23
    
try this sudo apt-get --purge remove crossplatformui* –  blade19899 Sep 26 '12 at 12:53
    
I get the same error again and again. how we get rid of this? –  sarat May 8 '13 at 4:52
add comment

marked as duplicate by Warren Hill, qbi, Jorge Castro, Eric Carvalho, user68186 Oct 17 '13 at 17:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

I've run into this before, first off, apt-get purge isn't always the best way to remove a package (sometimes removes more than it's supposed to)

Secondly, you might want to try sudo apt-get -f install and then if it installs it again, use sudo apt-get remove crossplatformui afterward, if you use said commands.

Hope this helps.

cody.smith

share|improve this answer
1  
no it doesnt reinstalls it and it shows same thing as above i mentioned. –  sarathprasath Sep 4 '12 at 2:25
    
I face the same problem but the solutions above did not work –  sarat May 8 '13 at 4:52
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.