Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Many answers on Ask Ubuntu direct to links like this that in Xubuntu opened in Ubuntu Software Center. In Lubuntu I get this error message:

enter image description here

In Firefox-Preferences/Applications cannot see something resembling to apt to associate to a program etc.

enter image description here

enter image description here

Opening the same link in Chromium or Opera I get:

enter image description here

Clicking "I'm running Ubuntu" results in an error message like in Firefox.

What's the remedy? Can I install Ubuntu Software Center?

share|improve this question
use apt://skype for example and install USC - Ubuntu Software Center – penreturns Sep 3 '12 at 9:51
up vote 9 down vote accepted

All you need to do is install the (Ubuntu) Software Center in Lubuntu.

Open a terminal, and type sudo apt-get install software-center. Then, the first time you click on a APT link in Firefox should give you the below popup, after which such links should open automatically:

enter image description here

enter image description here

Beside Ubuntu Software Center, a much lighter application (AptUrl) can be used to handle "apt://" protocol/links: see this answer to a related question.

share|improve this answer
well, thnx, i already got that a few sec before. but i have a new question: – cipricus Sep 3 '12 at 9:10
Oops, sorry, didn't notice that since I was already typing :) I'm looking at the other question. – izx Sep 3 '12 at 9:17
If he is on 12.04, is it not possible to use Lubuntu software-center instead? – jokerdino Sep 3 '12 at 10:39
LSC does not support the apt handler. (notice there are no MimeType lines in lsc.desktop) – izx Sep 3 '12 at 10:42
Considering that Ubuntu 13.10 software center doesn't have this functionality anymore by default, I doubt this will work. – NoBugs Dec 12 '13 at 4:37

Point the select application to:


This sould solve the problem.

Don't forget to check "Remember".

share|improve this answer

The issue is solved after installing Ubuntu Software Center, which was not installed.

sudo apt-get install software-center

Now, after opening that link in Firefox, it offers the normal option to open that link in Ubuntu Software Center, and to remember that option. Also, following this, apt appears in the list from Firefox' Preferences/Applications:

Preferences/Applications Screenshot

share|improve this answer

Here is what Firefox support page says about this:

The Applications panel has limited functionality for editing. You can change the action for an existing file type but you cannot add or remove file types. Entries are added automatically when you download files and select actions for them.

However, in your case you can try modifying you ~/.mozilla/firefox/\*\*\*\*.default/mimeTypes.rdf. Here is a link to mine:

share|improve this answer
see my question text: In Firefox-Preferences/Applications cannot see something resembling to apt to associate to a program. now i added images. also: Can I install Ubuntu Software Center?. i guess i can, and i'll try to – cipricus Sep 3 '12 at 8:38
up-vote for your responsiveness thnx, but you see i got the simplest way. the problem was simple: Lubuntu doesn't come with Ubuntu Software Center – cipricus Sep 3 '12 at 9:02

I solved this issue in lubuntu 14.04 by opening the link using the path /usr/bin/apturl I changed it in my firefox preferences for future use.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.