Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Everything was working, but today I get this error:

Could not find gem 'cgi (>= 0) ruby' in the gems available on this machine.

I have ruby1.9.1-dev installed.

share|improve this question
1  
Can you please explain what you are trying to do? what is the command you ran, that gave you this error? –  devav2 Sep 3 '12 at 9:46
    
it's rails bundle problem. When I try to run 'bundle install' in project directory it shows my this error instead of installing missing gems. –  precz Sep 4 '12 at 10:10

1 Answer 1

up vote 1 down vote accepted

It sounds like you're trying to install the "cgi" gem. It ships with Ruby, so there's no need for that step. Just "require"-ing it should be sufficient.

share|improve this answer
    
I have gem 'cgi' in Gemfile file, when I run 'bundle install', I get this error. –  precz Sep 4 '12 at 10:18
    
You were right, problem solved! –  precz Sep 4 '12 at 10:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.