Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to resize the Unity launcher. Is that possible?

share|improve this question
add comment

6 Answers

12.04 & Unity (3D)

The launcher icon size can be changed from a new option in System Settings - Appearance

enter image description here

You'll see a slide bar which allows you to change the launcher size.

Drag left to shrink

Minimum size 32 pixels

Drag right to expand

Maximum size 64 pixels

share|improve this answer
2  
I don't have the line that reads "Launcher icon size" although I just upgraded to 12.04 - How come I missed this one? –  itsols Jun 11 '12 at 6:26
1  
if you don't have that line - you are most probably running unity-2d not unity-3d - have a look at this Q&A to confirm: askubuntu.com/questions/62001/am-i-using-unity-or-unity-2d –  fossfreedom Jun 11 '12 at 6:29
    
I had the exact same problem. I had to switch to Unity 3D. –  nerof61 Jan 14 '13 at 17:22
add comment

Install ccsm from the software center . Now Press Alt + F2 and enter about:config

Then go to the Experimental tab. In the middle of the page is a slider that allows you to adjust the Launcher icon size from 32 to 64 pixels. You can also control backlighting and attention animations.

share|improve this answer
1  
Presumably correct at the time it was written, it is not currently the way to do this. See kelvinafox's answer. –  Simon Hoare Dec 23 '12 at 7:22
add comment

You should install MyUnity. You can see icon size option.

My Unity

Just set "Size".

share|improve this answer
    
Is there a way to get the buttons back instead? Plus, I don't really want to install something. Thanks for your help though. –  nerof61 Jan 2 '13 at 14:02
    
Sorry, that's only way than I know. :( –  ZDroid Jan 2 '13 at 14:06
add comment

FYI for Unity-2D users like myself. Worked for me under 12.04LTS.

http://www.dedoimedo.com/computers/ubuntu-unity-2d-resize-launcher.html

share|improve this answer
    
this is cool! At last I got my launcher resized :) –  itsols Jun 11 '12 at 6:54
    
That's how I felt. :) –  Rhino Jun 13 '12 at 23:54
1  
And there was BAD news :) --- Yesterday, was one of those updates taking place. Then I had to restart. And guess what... Yes, All my launcher settings were gone back to default. Oh no! Now I'm thinking if it's worth the trouble because the next update may just mess it up... again... And given that compiz doesn't work on my old laptop, it's not enjoyable making those changes by hand, just to have them lost with the next update. Anyway, this method of yours is what worked for me as I'm on Unity 2D. –  itsols Jun 14 '12 at 3:22
add comment

Right-click on the deskop, choose "Change Desktop Background" from the drop down menu. At the bottom of the window there should be a slider that says "Launcher icon size". Slider to the left is smaller icons, slider to the right is larger icons.

enter image description here

share|improve this answer
add comment

It is possible as of the latest Unity update.

Checkout my answer on How can I configure Unity? for details.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.