Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried setting MAILTO="" under /etc/crontab and /etc/default/cron, but I still receive mail notifications from cron. Is there a single place to disable all mail from cron, as opposed to per-task output redirection?

Thanks!

share|improve this question
up vote 1 down vote accepted

Open sudo crontab -e on terminal. At the top of the file set MAILTO=""

This should help you to disable email.

If need you can restart the cron using command /etc/init.d/crond restart

share|improve this answer
    
Well now I'm embarrassed. Having read many similar answers I tried going "under the hood" too much for my own good... Thanks a lot! – ezequiel-garzon Sep 3 '12 at 14:26
    
crond doesn't exist in my 14.04.4 but sudo /etc/init.d/crond restart works. – Torben Gundtofte-Bruun Mar 30 at 19:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.