Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Relatively far along in the LTS upgrade with a call to "apt-get distupgrade" there appeared:

E: could not perform immediate configuration on python-minimal

I tried installing python2.7-minimal. This generates the message:

dpkg: dependency problems prevent configuration of python2.7-minimal:
 python2.7-minimal depends on python-minimal (>= 2.6.6-3+squeeze1); however:
  Version of python-minimal on system is 2.6.5-0ubuntu1.
dpkg: error processing python2.7-minimal (--configure):

No doubt this is one of the challenges presented by the concept of an LTS upgrade. Is it safe to use force to replace python2.6-minimal with python2.7-minimal, and, if so, will it take care of the first error?

Any clues?

share|improve this question

closed as off-topic by Luis Alvarado Jul 26 '14 at 17:14

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Luis Alvarado
If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.