Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been running a ubuntu 10.04 with a patched version of lirc_zilog for two years. I upgraded to 12.04 and lirc_zilog is no longer working with my HD-PVR. The MythTV wiki reports that it did work out of the box with 11.04.

The error message I get on irsend is as follows:

johnf@carbon:~$ /usr/local/bin/irsend SEND_ONCE blaster 0_130_KEY_POWER
irsend: command failed: SEND_ONCE blaster 0_130_KEY_POWER
irsend: hardware does not support sending

The lircd daemon, run interactively, reports the following:

 lircd: accepted new client on /var/run/lirc/lircd
 lircd: could not get hardware features
 lircd: this device driver does not support the LIRC ioctl interface
 lircd: major number of /dev/lirc0 is 250
 lircd: LIRC major number is 61
 lircd: check if /dev/lirc0 is a LIRC device
 lircd: WARNING: Failed to initialize hardware
 lircd: error processing command: SEND_ONCE blaster 0_130_KEY_POWER
 lircd: hardware does not support sending
 lircd: removed client

Checking dmesg seems to indicate that the kernel module is loading properly:

 [56497.730743] lirc_zilog: module is from the staging directory, the quality is unknown, you have been warned.
 [56497.730999] lirc_zilog: Zilog/Hauppauge IR driver initializing
 [56497.732484] lirc_zilog: ir_probe: ir_rx_z8f0811_hdpvr on i2c-0 (Hauppage HD PVR I2C), client addr=0x71
 [56497.732493] lirc_zilog: ir_probe: ir_tx_z8f0811_hdpvr on i2c-0 (Hauppage HD PVR I2C), client addr=0x70
 [56497.732496] lirc_zilog: probing IR Tx on Hauppage HD PVR I2C (i2c-0)
 [56497.756822] lirc_zilog: firmware of size 302355 loaded
 [56497.756945] lirc_zilog: 743 IR blaster codesets loaded
 [56497.757030] i2c i2c-0: lirc_dev: driver lirc_zilog registered at minor = 0
 [56497.757033] lirc_zilog: IR unit on Hauppage HD PVR I2C (i2c-0) registered as lirc0 and ready
 [56497.757035] lirc_zilog: probe of IR Tx on Hauppage HD PVR I2C (i2c-0) done
 [56497.757056] lirc_zilog: initialization complete

Here is my /etc/lirc/hardware.conf

 #Chosen IR Transmitter
 TRANSMITTER="HD-PVR"
 TRANSMITTER_MODULES="lirc_dev lirc_zilog"
 TRANSMITTER_DRIVER=""
 TRANSMITTER_DEVICE="/dev/lirc0"
 TRANSMITTER_SOCKET=""
 TRANSMITTER_LIRCD_CONF=""
 TRANSMITTER_LIRCD_ARGS=""

My lircd.conf is a copy of the recommended one.

Examination of the kernel source seems to indicate that the lirc_zilog module should support transmission, it's newer than the patched version I was manually compiling on 10.04. I was previously using a manually built version of lirc 0.8.7 and not the packaged one. I'm now running the packaged version 9.0.

I can provide any additional information required and will perform tests quickly. I'm very eager to get this issue resolved.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

That's odd...it works out of the box for me with 12.04.

Why are you using /usr/local/bin/irsend instead of the one in /usr/bin/irsend?

Here is an irsend command that works for me:

/usr/bin/irsend --device=/dev/lircd SEND_ONCE blaster 1_27_KEY_2

Perhaps you need to specify --device, and use the binary in /usr/bin?

share|improve this answer
    
You raise a very interesting point, I was previously using that path to reference the version I'd compiled manually. Strangely, after rebooting my system both irsend binaries are now working. I have no idea why/how this could happen with the large number of service restarts I performed and kernel module reloads but I am happy it works! –  johnf Sep 5 '12 at 1:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.