Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So i'm having problems running psychonauts as i've noticed many others have as well. I installed it through software center and made sure i had the right libs needed to run mesa (libtxc-dxtn-s2tc0:i386, since i'm running a 64-bit system). I should start by saying I'm not sure whether it will run smoothly on my notebook anyway. Saw something about a missing OpenGL-extension i'm not sure what that means but i'm guessing it's trouble. But i run a Fujitsu Siemens amilo sa3650 which comes with an external graphics card so i might be able to make it run smoothly with that later, just haven't configured it yet. So I just want to see if I can make it run at all first.

When i try running it by forcing S3TC support with:

force_s3tc_enable=true /opt/psychonauts/Psychonauts   

I get this output

    STUBBED: fix up the rest of the SSE code first at DetectSSESupport (/home/icculus/projects/psychonauts/Source/CommonLibs/DFMath/MathGeneral.cpp:32)
    STUBBED: write me? at SetPCLanguage               (/home/icculus/projects/psychonauts/Source/game/luatest/UnixMain.cpp:120)
    STUBBED: fix up the rest of the SSE code first at DetectCPUCaps (/home/icculus/projects/psychonauts/Source/game/luatest/Game/PCGameApp.cpp:223)
    STUBBED: check LANG envr var at _GetDefaultGameLanguage   (/home/icculus/projects/psychonauts/Source/game/luatest/Game/GameApp.cpp:171)
    Console created
    Save  path: /home/alex/.local/share/Psychonauts
    Write path: WorkResource
    STUBBED: inline asm at SSEMul_4x4_4x4_2arg         (/home/icculus/projects/psychonauts/Source/CommonLibs/DFMath/Matrix.cpp:710)
    STUBBED: inline asm at SSEMul_4x4_4x4_3arg       (/home/icculus/projects/psychonauts/Source/CommonLibs/DFMath/Matrix.cpp:698)
    ******** unit test failed ********
    STUBBED: VK_* at InitInputNames       (/home/icculus/projects/psychonauts/Source/CommonLibs/DirectX/SDLInput.cpp:1220)
    No joysticks detected
    Transport started
    DaveD: NCListenSocket: Listening on port 40001
    ERROR: Missing required OpenGL extensions:
        - GL_ARB_vertex_buffer_object
    Start Up completed in 0.27 seconds
    Segmenteringsfel (minnesutskrift skapad)

It's in swedish, so if it's something you don't understand (you can probably guess most thing just from the context it's in) you'll have to ask me and i'll translate.

Now, what should i do? Maybe I should add that i did try to install it just by manually downloading and running the bin-file from the humble bundle-website. I did this before trying it through software center. I got the same results. And i tried the S3TC-thing and made sure I hade the right libs after installing by that method as well.

Any suggestions would be very helpful.

PS. Love askubuntu! It has helped me with a lot of problems without me having to post a question before but for this I couldn't quite find any question that was about the same problem.

EDIT: I'm running ubuntu 12.04 64-bit version.

share|improve this question
    
When running apt-get update i get some 404-messages. A lot of which seem to be about i386 and "amd64". I'm a novice but 404 means somethings wrong with the server or the mirror or whatever, right? But since a lot of my 404's seem to about my OS being a 64-bit-build, could that mean that something's messed up, specifically with the repositories used for 64-bit packages? Am I maybe using the wrong ones? I'll look into this and hope for some feedback. –  Alex Sep 2 '12 at 23:46
    
I fixed the problem with the 404's but after learning more about sources and mirrors i realize how little that probably had to do with my original problem. After reading the psychonauts-output more closely it looks like there's something wrong with the coding of the program itself. How come and how can i solve it? I'm sorry if all this seems like i'm stating super-obvious stuff but for a novice like me i'm learning a lot of basic stuff about ubuntu just by looking for solutions to problems like this. So it helps to sort of vent it, even though it's just a monologue so far. –  Alex Sep 3 '12 at 13:27
    
404 errors are misses on repos, either the mirror is down or miscofngiured, but the default sources will have alternate mirrors to check, this will only affect you being able to see/download packages not anything else. As for your actual problem, what are your system specs? Drivers that you are running and such. You say you have an external graphics card, but if you are running it on an embedded card currently without opengl drivers that would cause the program not to start. In other words, opengl issues, in my mind = graphics driver issues. –  crasic May 10 at 17:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.