Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu 12.04 on a Dell Studio 15 and so far am really impressed.

I could not find a solution for my problem by googling.

The fonts on some websites do not have proper spacing. they overlap and are very hard to read that way. I am using the Ubuntu standard fonts and have not changed them after installing.

Here is a screen shot that shows my problem.

line spacing browser issue

The problem occurs in Firefox and Chrome the same way, and on the same websites.

Thanks for your help.

share|improve this question
What's the browser, also any browser add-ons installed? Also, is the screen shot from your machine? – Tom Brossman Sep 2 '12 at 16:02
It happens in Google Chrome, Chromium, and Firefox. It looks exactly the same. I have Add-Ons installed and disabled them one by one. That didn't fix it. Yes, the screenshot is from my machine. – elgubbo Sep 2 '12 at 16:22
Sorry, you said the browsers in the question and I missed it. Can you check System Settings/Universal Access/Seeing/Text Size and see if it is set to 'Normal'? – Tom Brossman Sep 2 '12 at 16:47
thanks for your help! Text size is set to "Normal" in the settings you mentioned. i thought it might be an issue with webkit browsers, so i tried opera(i think opera is using its own engine but i am not sure), but i got the same results in opera. – elgubbo Sep 2 '12 at 16:53
@user950731 this might not be the case. because that page is looking fine on a newly installed Ubuntu in Firefox. Have you installed any software/package which might interact with gui? or used some package like that? – Anwar Shah Sep 2 '12 at 19:24

it was "Helvetica" for me. Had to install for some Scribus compatibility and since started noticing fonts overlapping everywhere - documents, web pages, web-based editors. Removing the font fixed the issue.

Yet to figure out why the incompatibility but as far as this issue is concerned, look for that font or any other recently installed fonts.

share|improve this answer

In Firefox, check your zoom setting and character encoding. Reset the former and the usual default for the latter is UTF-8.

share|improve this answer
I reset the zoom settings and character encoding is set to UTF-8. Still looks the same. – elgubbo Sep 2 '12 at 16:24

Finally! i fixed it.

there where some botched fonts installend in my /home/.fonts/ directory.

I deleted them now everything is fine.

share|improve this answer
I removed Helvetica_Regular.ttf from the .fonts directory (which I had installed to edit some pdf in inkscape) and the problem is gone. – fuenfundachtzig Dec 16 '13 at 21:50

Please make sure that you have updated your system.

You could try (however I think that might not help ...) to install ms core fonts from the software center (just search for that). Many websites use these fonts, so that could be a problem.

I do not experience this issue in firefox

share|improve this answer
thank you for your answer. my system is up to date as far is i can tell. (just did apt-get update and apt-get upgrade). i also have the corefonts installed. – elgubbo Sep 2 '12 at 15:52

I had the same problem in a 11.10 version of Ubuntu. As far as I remember it occured after accidentally deleting one of the system fonts from /usr/share/fonts . I upgraded to 12.04 in the meantime but the problem persists. I noticed that installing some fonts fixes the problem on some pages but not on all of them (can remember exactly now but I think that after installing mscore-fonts a dreamhost page started displaying correctlly) . I suspect that the default browser serif or sans-serif might be missing or sth...

in my case also sometimes fonts are too big for a text field or underline is crossing them out instead.


I managed to confirm that problem is caused by badly installed or missing fonts. I repaired display on github page deactivating my Helvetica font using 'font manager' (you can download it from software center), and it started rendering Arial instead. It seems like Helvetica installed on my system had wrong spacing or sth.

You can check the fonts used on websites using Mozilla firebug plugin, and 'inspect element' css styles 'font-family'.

hope it helps

share|improve this answer
sudo apt-get install xfs xfstt

This fixed it for me, after much troubleshoting with fonts.

Seems like I managed to uninstall it somehow.

share|improve this answer

do you install ubuntu-restricted-extras ?

sudo apt-get install ubuntu-restricted-extras

this package have

    Installer for Microsoft TrueType core fonts 
share|improve this answer
That's not going to help. He already has core fonts, and may not need all the restricted extras. – Tom Brossman Sep 2 '12 at 16:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.