Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed lamp with this tutorial a while back: http://www.unixmen.com/install-lamp-with-1-command-in-ubuntu-1010-maverick-meerkat/

I have since decided it would be better to use the more full-featured Xampp. I installed Xampp successfully, but localhost still displays the default apache page. Apparently, I need to uninstall the lamp components individually to use Xampp. Any advice on how best to do this?

share|improve this question

1 Answer 1

I would suggest you to remove the following packages :

  • libapache2-mod-auth-mysql
  • phpmyadmin
  • mysql-server
  • mysql-server-
  • mysql-server-core-
  • apache2 and related modules
  • libapache2-mod-php5

use sudo apt-get purge <package_name> to remove the packages.

Below text is grabbed from here:

Starting over: How to remove the LAMP stack To remove the LAMP stack remove the following packages:

Note: This assumes you have no other programs that require any of these packages. You might wish to simulate this removal first, and only remove the packages that don't cause removal of something desired.

apache2 apache2-mpm-prefork apache2-utils apache2.2-common libapache2-mod-php5 libapr1 libaprutil1 libdbd-mysql-perl libdbi-perl

libmysqlclient15off libnet-daemon-perl libplrpc-perl libpq5 mysql-client-5.0 mysql-common mysql-server mysql-server-5.0 php5-common php5-mysql

To also remove the debconf data, use the purge option when removing. To get rid of any configurations you may have made to apache, manually remove the /etc/apache2 directory once the packages have been removed.

share|improve this answer
    
I've done everything that you've described as far as I can tell - still no luck. Any other thoughts or resources? –  southpointingchariot Sep 2 '12 at 16:43
    
Ah, I needed to reinstall XAMPP. Thank you! –  southpointingchariot Sep 2 '12 at 17:41
    
Good that you found the fix. If you found this answer helpful then mark it as answered. Thanks –  devav2 Sep 2 '12 at 18:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.