Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Wish I was here with good news today but as my luck has it I'm afraid I'm not :(

I recently bought a new graphics card (sapphire HD 7870) and installed it into my system ... went well up to there ...

I tried updating the driver but won't able to in additional drivers.

I then tried this page http://wiki.cchtml.com/index.php/Ubuntu_Precise_Installation_Guide

now when I try anything this message comes up

"The package fglrx needs to be reinstalled, but I can't find an archive for it"

I am at the minute downloading (found on link above)

Download the latest Catalyst package.

This package contains both the 32-bit and 64-bit driver.

(I'm on first step) ... slow Internet ... yay +_+

wget http://www2.ati.com/drivers/linux/amd-driver-installer-12-8-x86.x86_64.zip
unzip amd-driver-installer-12-8-x86.x86_64.zip
chmod +x amd-driver-installer-8.982-x86.x86_64.run

any pages or info anybody may have shall be greatly appreciated

can provide more information if needs be Release 12.04 (precise) 64-bit Kernel Linux 3.2.0-29-generic GNOME 3.4.2

oh and i can't open "additional drivers" now

share|improve this question
add comment

2 Answers 2

A quick and easy way to install the driver for your Ati card would be to open terminal and type these lines in and hit enter:

sudo apt-get install fglrx fglrx-amdcccle
sudo aticonfig --initial
fglrxinfo

Now reboot and your card should be working.

share|improve this answer
    
ATI has been AMD now since 2006 lol. –  Marco Scannadinari Sep 17 '12 at 19:19
add comment

the chmod command was unnecessary. After the .run file is unzipped, execute the following commands:

sudo -s

cd [location of extracted .run file]

sh amd-driver-installer* --buildpkg Ubuntu/precise

It will then build 3 packages - fglrx, fglrx-amdcccle, and fglrx-dev after about one or two minutes.

After the ackages have been generated, execute the following code:

cd [the location of the newly-built packages]

dpkg -i fglrx_8*.deb && dpkg -i fglrx-amdcccle*.deb && dpkg -i fglrx-dev*.deb

... Then delete any 'Xorg.conf's you might have in /etc/X11/ and run:

sudo amdconfig --initial

sudo reboot

Then run sudo amdconfig --initial again. To double check everything is working, run fglrxinfo - Make sure that there is no mention of VESA. The output should look like this:

fglrxinfo display: :0 screen: 0 
OpenGL vendor string: Advanced Micro Devices, Inc. 
OpenGL renderer string: AMD Radeon HD 6300M Series 
OpenGL version string: 4.2.11733 Compatibility Profile Context
share|improve this answer
    
... And to test out your new driver, install teeworlds sudo apt-get installl teeworlds! –  Marco Scannadinari Sep 17 '12 at 19:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.