Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to do automated installation using preseeding from url, but it failed.

Basically, I'm following

Ubuntu Server Quick Install, No Questions Asked! http://blog.dustinkirkland.com/2011/03/ubuntu-server-quick-install-no.html

Using the Ubuntu 12.04 desktop ISO, and append the following options to the kernel command line (ESC, then F6 at the boot screen):

priority=critical locale=en_US url=http://goo.gl/PBKbX

The installation should proceed from start to finish, but mine failed at the first step resolving goo.gl.

what's wrong?

I also tried to add auto, as per https://help.ubuntu.com/12.04/installation-guide/i386/preseed-using.html ie., appending

priority=critical locale=en_US auto url=http://goo.gl/PBKbX

but still, can't resolve goo.gl

How can I fix it?

PS. this is run from within VirtualBox.

share|improve this question
    
Have you tried it without using goo.gl to shorten the links? –  Mateo Mar 27 '13 at 20:52
add comment

2 Answers

Modifying the desktop ISO with ISO Master works for me.

  1. Run ISO Master in the bottom pane.

  2. Open the isolinux directory.

  3. Edit the txt.cfg file.

    I added the following entry (changed the url though)

    default live
    label live
    menu label ^Autoinstall
    kernel /casper/vmlinuz
    append  url=http://goo.gl/PBKbX/live.seed automatic-ubiquity boot=casper initrd=/casper/initrd.lz quiet splash noprompt auto=true --
    
  4. Save the image and try it.

I assume setting the kernel options manually should work as well. Make sure you have set the VirtualBox network settings correctly (e.g useing NAT).

share|improve this answer
    
What are you linking to with goo.gl, this is confusing, and using link shortening services is frowned upon. –  Mateo Mar 27 '13 at 20:13
add comment

Change the network adapter mode in virtualbox to 'Bridge' instead of NAT. Sometimes NAT doesn't get you proper networking access, and therefore your DNS lookup will fail.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.