Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I observed that the shortcut for closing a tab in Firefox (Ctrl+F4) doesn't work on KDE. It seems it is being intercepted by KWin.

Is there any fix or workaround for this problem?

share|improve this question
1  
Strange, I always used ctrl+W to close tabs. Both work perfectly for me though (although I'm using Gnome at the moment). –  KIAaze Sep 2 '12 at 6:15
    
@KIAaze: Thanks for the comment. This solved my problem. Ctrl+W is a lot easier than pressing Ctrl+F4. I'm using Linux Mint 15. –  Ufoguy Dec 11 '13 at 10:08

1 Answer 1

up vote 10 down vote accepted

The reason Ctrl-F4 doesn't work in KDE is because KWin uses the same keyboard shortcut for switching between workspaces. If you would really want to use Ctrl-F4, you might want to consider editing the KWin keyboard settings.

To do that, open System Settings and go to Shortcuts and Gestures.

System settings

Then navigate to Global Keyboard Shortcuts and choose Kwin from the KDE component dropdown.

Kwin

Scroll down all the way until you see Switch to Desktop 4 option. Click on the shortcut and choose Custom and either select a different shortcut or leave it as empty.

Removing the shortcut

You should now be able to use Ctrl-F4 to close tabs in Firefox.


Related:

share|improve this answer
    
Thanks for the quick reply! –  Anwar Shah Sep 2 '12 at 7:20
    
If you don't want to do all this then just use Ctrl+W instead. It works perfectly in Linux Mint 15. –  Ufoguy Dec 11 '13 at 10:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.