Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Story:

I have a HP dv7 1020us with a Nvidia GeForce 9600M GT. My internal monitor is broken, so essentially I cant' use it, as I can hardly see anything through it.

Laptop screen

Recently, I upgraded to Ubuntu 12.10 (manually, using synaptic to upgrade packages bit by bit), and after getting most of the system upgraded, I decided to go for the new kernel, X, and nvidia-drivers.

Unfortunately, it seems that something, whether xrandr, or the nvidia driver, is reading my external monitor incorrectly. Nvidia settings is not allowing me to clone the screen as it did before (I have it set to clone, but it acts as if I have two separate screens).

Lightdm only shows on the internal screen, which is not useful because although I can login, I can't actually see what I'm gdoing.

Xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 304.37  (buildd@batsu)  Tue Aug 28 15:15:30 UTC 2012

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.43  (buildmeister@swio-display-x86-rhel47-13)  Sun Aug 19 21:19:28 PDT 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LPL"
    HorizSync       30.0 - 75.0
    VertRefresh     59.9
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9600M GT"
EndSection

Section "Screen"

# Removed Option "nvidiaXineramaInfoOrder" "DFP-0"
# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0, CRT: 1440x900 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "DFP: nvidia-auto-select +0+0, CRT: 1440x900 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Nvidia-settings:

Nvidia settings

Unity:

With cloning on, this is what I get:
Unity
This is likely a bug in Unity, but as I can't switch sessions on login, I can't be sure :)! (woo hoo!)

Xrandr output:

xrandr
Screen 0: minimum 8 x 8, current 1280 x 1024, maximum 8192 x 8192
VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 320mm x 240mm
   1024x768       85.0 +   75.0  
   1280x1024      60.0* 
   800x600        85.1     75.0  
   640x480        85.0     75.0     59.9  
LVDS-0 connected (normal left inverted right x axis y axis)
   1440x900       59.9 +
HDMI-0 disconnected (normal left inverted right x axis y axis)

My Monitor:

My monitor is a Compaq 7500 CRT monitor. Google searching says that the max res is indeed 1280x1024, but I have used it at 1440x900 for over a year now - so yes, it can achieve the laptop's resolution. I think the problem is that it is being reported as the wrong kind of monitor:

Display Settings

This is incorrect, as it is a 17" monitor, and it supports way more resolution options that it's displaying.


Now, what can I do to at least work around these issues (I know I need to report a bug or two, but I need to get this fixed as well) and force my monitor to correct resolution?

P.S. I created a topic for this on the Ubuntu forums (it's just a merry go round, so I came here as a last resort). The suggestion I got is to downgrade to the 295.xx driver - but because of the way nvidia's driver has to be installed, I don't think this is an option unless there is a graphical way to do this.

You see, if I switch to a tty (Required for installing), the CRT is disabled.

Current situation:

I have disabled the laptop screen and written the changes to the xorg.conf. Adding 1440x900 as a meta mode made no difference, because the monitor is still being detected incorrectly. It seems I need the right EDID for this CRT.

Anyway. Right now, what I would like to do is to have Lightdm use the correct resolution on login (at least 1280x1024). How can change at least this setting?

share|improve this question
    
I don't know but I've been told that cleaning toilet latrines gets mighty old! –  TheX Sep 2 '12 at 0:57
1  
@TheX: That's deep! I'm going to do my reps now. –  RolandiXor Sep 2 '12 at 1:03

1 Answer 1

Having just gone through the horror of installing nvidia drivers, I'd venture a guess and say that they didn't install quite right. Some of the symptoms you describe are similar to what I battled.

I Couldn't get the drivers to function properly using the nvidia-drivers package. I had to do a binary install. I used these instructions here: http://ubuntuforums.org/showthread.php?t=2081649

The one difference, I had to install the sudo apt-get install linux-headers-3.5.0-17-generic

Then the install was finally successful.

HTH

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.