Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

At the moment I'm running Ubuntu Server 12.04 on top of a VirtualBox running as service in Microsoft Windows7 x64. I've configured the shares on fstab with

E /media/E vboxsf auto,rw,uid=1000,gid=1000 0 0

the mount is OK

drwxrwxrwx  1 knoker knoker 16384 Sep  1 20:02 E

but I cant change the permissions inside of /media/E, chmod runs but doesn't do nothing.

On a specific case /media/E/Docs/Downloads I have

dr-xr-xr-x 1 knoker knoker     163840 Sep  1 19:30 Downloads

and since I can't seem to be able to change from Linux, I tried it on the Windows, and all users listed have full control.

Any ideas on what is happening?

share|improve this question
add comment

1 Answer

why argue with stupid... i solved it by creating another folder, copying the content of the downloads to the new folder, deleted the downloads folder and renamed the new folder downloads, and BAM:

drwxrwxrwx 1 knoker knoker 98304 Sep 2 00:07 downloads

this is not the perfect solution but it works tho... As of why i was having the problem in the first place is still a mystery...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.