Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my laptop, when I have dual monitors, my laptop screen resolution is 1680x1050. Nevertheless, when I disconect the second screen and restart the laptop, the screen resolution drop to 1400x1050 and I have no opportunity to set it back to 1680x1050.

Any idea why I only get the right resolution of my laptop screen in dual monitors?

share|improve this question
    
sounds like your laptop is faking that resolution in some way. anyways, without the info about your graphics card/chip + driver - we can't be much help to you. –  RolandiXor Dec 20 '10 at 23:55
add comment

1 Answer 1

xorg works very strangely without specific resolution settings within /etc/X11/xorg.conf

You need to put the specific resolutions and it would work perfectly.

Here is how I set up my xorg.conf and you can use this as a guide for yours (search on google for your resolution) or for a short time you can backup yours and use this one but it will let you use a maximum resolution of 1024x768@60Hz (I love this xorg.conf):

Section "InputDevice"

    Identifier  "Generic Keyboard"
    Driver      "kbd"
    Option      "XkbRules"  "xorg"
    Option      "XkbModel"  "pc105"
    Option      "XkbLayout" "ro"
EndSection

Section "InputDevice"

    Identifier  "Configured Mouse"
    Driver      "mouse"
EndSection

Section "Device"
    Identifier  "Configured Video Device"
EndSection

Section "Monitor"
    Identifier  "Configured Monitor"
    Modelname "Custom 1"
    modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
    modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
    modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
EndSection

Section "Screen"

    Identifier  "Default Screen"
    Monitor     "Configured Monitor"

    SubSection "Display"

        Depth 24
        Modes "1024x768@60" "800x600@60" "640x400@60"
        Modes "800x600@60" "640x400@60"

    EndSubSection

EndSection
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.