Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Sorry if this is a stupid question; I'm a newbie.

I am preparing a manuscript in LaTeX. The journal (Physical Biology, an IOP publication) requires that figures be saved in .eps format, so I am trying to do that. However, I cannot get my LaTeX file to build when I have generated the .eps files on my Ubuntu computer. If I save the images on my Mac, the file build just fine.

So far, I have tried saving images in ImageJ, FIJI and Inkscape. The same problem occurs in all three. When using kile, I get the following error:

/usr/share/texmf-texlive/tex/latex/oberdiek/epstopdf-base.sty:0: Shell escape feature is not enabled.

In TexWorks, the error is different, but still there:

Package pdftex.def Error: File `./figures4/figure4a-eps-converted-to.pdf' not found.

Now, if I fire up Inkscape, FIJI or ImageJ on OS/X, everything works fine. The Mac also can't build with the Ubuntu-saved images.

The images generated on the Ubuntu machine open fine using Document Viewer. I am building the same LaTeX file on both computers, with the exact same results. The header of my LaTeX file is:


And then the code for the figure is:

    \footnotesize{\caption{ \label{fig:4a} (4a)  lorem ipsum dolor sic amet.}}

I'd be happy to send an example of both .eps files. Again, sorry if this is a dumb question. I tried everything I could think of before posting here.

Thanks, David

share|improve this question
pdflatex can not read .eps files, they must be converted (to pdf). Modern TeX installations do this on-the-fly, but that needs shell escape. – Martin Schröder Sep 2 '12 at 12:02
up vote 1 down vote accepted

According to section 2.16 of the TexShop documentation ("Shell escape protection"), the shell escape feature is to allow pdflatex to run other programs during compilation. In particular, the epstopdf package you are using to convert eps to pdf is such a program (incidentally, you don't have to explicitly turn that on anymore in the latest versions of TeXLive).

I am not familiar with kile or TeXWorks, but I expect they have an option in the preferences that let's you turn on the shell escape, just as in TeXShop. You can also explicitly compile your LaTeX file from the command line: pdflatex --shell-escape file.tex where file.tex is the name of your file.

It sounds like the reason you can typeset your file on the Mac but not Ubuntu, is either: 1) Your Mac version(s) of your TeX apps have shell escape enabled, or 2) When you make your eps file on the Mac, it additionally creates pdf versions, which are later found by your TeX app and so no conversion from eps is needed.

share|improve this answer
Thank you! When I enabled shell escape, it worked. – David B Borenstein Sep 2 '12 at 0:03
@DavidBBorenstein Glad to hear it! – Chan-Ho Suh Sep 2 '12 at 1:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.