Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After a failed LTS upgrade from Lucid to Precise, I'm stuck in package limbo. As root I have run

dpkg --configure -a
apt-get -f install

Outputs appended below.

The default package archive at this point contains packages for Precise. What should I do to get past this?

------------------------------------------------------------
In response to:   dpkg --configure -a

dpkg: dependency problems prevent configuration of xserver-xorg-video-vmware:
 xserver-xorg-video-vmware depends on libxatracker1; however:
  Package libxatracker1 is not installed.
dpkg: dependency problems prevent configuration of xserver-xorg-video-intel:
 xserver-xorg-video-intel depends on libxcb-dri2-0; however:
  Package libxcb-dri2-0 is not installed.
 xserver-xorg-video-intel depends on libxcb-util0 (>= 0.3.8); however:
  Package libxcb-util0 is not installed.
Errors were encountered while processing:
 xserver-xorg-video-vmware
 xserver-xorg-video-intel

In response to:   apt-get -f install

Reading package lists...
Building dependency tree...
Reading state information...
Correcting dependencies... failed.
The following packages have unmet dependencies:
  gvfs-bin: Depends: gvfs (= 1.6.1-0ubuntu1build1) but 1.12.1-0ubuntu1 is installed
  gvfs-fuse: Depends: libgvfscommon0 (>= 1.1.7) but it is not installable
         Depends: gvfs (= 1.6.1-0ubuntu1build1) but 1.12.1-0ubuntu1 is installed
  initramfs-tools: Depends: initramfs-tools-bin (= 0.92bubuntu78) but 0.99ubuntu13 is installed
  libglib2.0-0-dbg: Depends: libglib2.0-0 (= 2.24.1-0ubuntu1) but 2.32.3-0ubuntu1 is installed
  libglib2.0-dev: Depends: libglib2.0-0 (= 2.24.1-0ubuntu1) but 2.32.3-0ubuntu1 is installed
  libnih1: Depends: libc6 (< 2.12) but 2.15-0ubuntu10 is installed
  plymouth: Depends: libdrm-nouveau1 (>= 2.4.11-1ubuntu1~) but it is not installable
  python-louis: Depends: liblouis0 (>= 1.7.0-2) but it is not installable
  xserver-xorg-video-all: Depends: xserver-xorg-video-nv but it is not installable
                      Depends: xserver-xorg-video-v4l but it is not installable
  xserver-xorg-video-intel: Depends: libxcb-dri2-0 but it is not installed
                        Depends: libxcb-util0 (>= 0.3.8) but it is not installed
  xserver-xorg-video-vmware: Depends: libxatracker1 but it is not installed

------------------------------------------------------------
share|improve this question
    
Kept fussing with it. –  William F. Hammond Sep 2 '12 at 23:26
    
Decided to use dpkg -i on the .debs in /var/cache/apt/archive for libxatracker1, libxcb-dri2-0, and libxcb-util0. This succeeded. –  William F. Hammond Sep 2 '12 at 23:29
    
Then "apt-get update" (which did find new things), "dkpg --configure -a", and "apt-get -f install" broke the log jam. So I could get then get quite a bit farther with "apt-get dist-upgrade", to the point where the system booted normally apart from bringing up X11 and some form of desktop. New issue to follow. –  William F. Hammond Sep 2 '12 at 23:33
    
BTW, there were dependency issues with gvfs to work around. –  William F. Hammond Sep 2 '12 at 23:35
2  
You should probably add your solution as answer, so that other see this is solved and can try it if they have the same problem. –  jP_wanN Sep 4 '12 at 17:04
show 1 more comment

2 Answers

why not try

sudo rm /var/lib/dpkg/lock

dpkg --configure -a

apt-get -f install package name here
share|improve this answer
add comment

I'm running into a similar problem and none of the solutions have worked to resolve this so far.

    apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
  bsdmainutils: Depends: cpp but it is not installed
  g++: Depends: cpp (>= 4:4.2.3-1ubuntu6) but it is not installed
  gcc: Depends: cpp (>= 4:4.6.3-1ubuntu5) but it is not installed
       Depends: gcc-4.6 (>= 4.6.3-1~) but it is not installed
  gedit: Depends: python2.5 (>= 2.5) but it is not installable
         Depends: python-gtksourceview2 (>= 2.2.0) but it is not installed
         Recommends: python-gnome2 but it is not installed
  gimp: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
  gnome-about: Depends: python-gnome2 but it is not installed
  gnome-app-install: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
                     Depends: python-gconf but it is not installed
                     Depends: python-launchpad-integration but it is not installed
                     Depends: python-sexy but it is not installable
  gnome-games: Depends: python-gnome2 but it is not installed
               Depends: python-gnome2-desktop (>= 2.17.3) but it is not installable
  gnome-orca: Depends: python-pyatspi
              Depends: python-gnome2 (>= 2.6.2) but it is not installed
              Depends: python-gnome2-desktop but it is not installable
  gnome-panel: Depends: gnome-control-center (>= 1:2.8.2-3) but it is not installed
               Recommends: alacarte but it is not installed
  gnome-session: Depends: gnome-control-center (>= 1:2.22) but it is not installed
  gtk2-engines-pixbuf: Depends: libgtk2.0-0 (= 2.20.1-0ubuntu2.1) but 2.24.10-0ubuntu6 is installed
  hal-cups-utils: Depends: python-usb but it is not installed
                  Recommends: hplip but it is not installed
  ifupdown: Depends: initscripts (>= 2.88dsf-13.3) but 2.86.ds1-59ubuntu13 is installed
  initramfs-tools: Depends: initramfs-tools-bin (>= 0.99ubuntu13.5) but it is not installed
                   Depends: initramfs-tools-bin (< 0.99ubuntu13.5.1~) but it is not installed
  jockey-common: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
  language-support-writing-en: Depends: hunspell-en-us but it is not installed
  libattr1-dev: Depends: libattr1 (= 1:2.4.46-3) but 1:2.4.46-5ubuntu1 is installed
  libc-dev-bin: Depends: libc6 (< 2.12)
                Recommends: manpages-dev but it is not installed
  libc6: Conflicts: libc6-i686
  libc6-dev: Depends: libc-dev-bin (= 2.15-0ubuntu10.5) but 2.11.1-0ubuntu7.13 is installed
             Breaks: binutils (< 2.20.1-1) but 2.18.93.20081009-0ubuntu1 is installed
             Breaks: gcc-4.4-base (< 4.4.6-3ubuntu1) but 4.4.3-4ubuntu5.1 is installed
             Breaks: make (< 3.81-8.1) but 3.81-5 is installed
             Breaks: pkg-config (< 0.26-1) but 0.22-1 is installed
  libc6-i686: PreDepends: libc6 (= 2.11.1-0ubuntu7.13)
  libgail18: Depends: libgtk2.0-0 (= 2.20.1-0ubuntu2.1) but 2.24.10-0ubuntu6 is installed
  libgdk-pixbuf2.0-0: Depends: libjpeg8 (>= 8c) but it is not installed
                      Depends: libgdk-pixbuf2.0-common (= 2.26.1-1) but it is not installed
                      Breaks: libgtk2.0-bin (< 2.21.3) but 2.14.4-0ubuntu1 is installed
                      Breaks: librsvg2-2 (< 2.26.3-2) but 2.26.3-0ubuntu1.1 is installed
                      Breaks: libwmf0.2-7 (< 0.2.8.4-7) but 0.2.8.4-6ubuntu0.8.10.1 is installed
  libglib2.0-0: Depends: libpcre3 (>= 8.10) but 7.8-3build1 is installed
                Breaks: gnome-session (< 3.0.0-3) but 2.24.1-0ubuntu1 is installed
                Breaks: gvfs (< 1.8) but 1.0.2-0ubuntu3 is installed
  libgtk2.0-0: Depends: libpango1.0-0 (>= 1.28.3) but 1.22.2-0ubuntu1.1 is installed
               Depends: libx11-6 (>= 2:1.4.99.1) but 2:1.1.5-2ubuntu1.1 is installed
  libidl0: Depends: cpp but it is not installed
  libnih1: Depends: libc6 (< 2.12)
  libpython2.6: Depends: python2.6 (= 2.6.5-1ubuntu6.3) but it is not installable
  libssl-dev: Depends: zlib1g-dev but it is not installed
              Recommends: libssl-doc but it is not installed
  libssl1.0.0: Breaks: openssh-client (< 1:5.9p1-4) but 1:5.1p1-3ubuntu1 is installed
  nautilus: Depends: gnome-control-center (>= 2.6) but it is not installed
  onboard: Depends: python-gconf but it is not installed
           Depends: python-virtkey (>= 0.50) but it is not installed
  openoffice.org-emailmerge: Depends: python-uno but it is not installed
  python-apport: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
                 Depends: python-problem-report (>= 0.94) but it is not installed
  python-beagle: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
  python-brlapi: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
  python-cairo: Depends: python (< 2.7) but 2.7.3-0ubuntu2 is installed
  python-cups: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
  python-cupshelpers: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
  python-dbus: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
  python-gdbm: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
  python-gi: Depends: gir1.2-glib-2.0 (>= 1.31.0) but 1.30.0-0ubuntu2 is installed
  python-gmenu: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
  python-gst0.10: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
  python-gtkhtml2: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
  python-launchpad-bugs: Depends: python2.5 but it is not installable
  python-libxml2: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
  python-minimal: Breaks: python-support (< 1.0.10ubuntu2) but 1.0.4ubuntu1 is installed
  python-notify: Depends: python (< 2.6) but 2.7.3-0ubuntu2 is installed
  python2.7: Depends: libdb5.1 but it is not installed
  rhythmbox: Depends: python2.5 (>= 2.5) but it is not installable
             Depends: python-gnome2 (>= 2.18) but it is not installed
             Recommends: yelp but it is not installed
  system-config-printer-gnome: Depends: python-gnome2 but it is not installed
  totem: Depends: totem-gstreamer (>= 2.24.3-0ubuntu1) but it is not installable or
                  totem-xine (>= 2.24.3-0ubuntu1) but it is not installable
  totem-mozilla: Depends: totem-gstreamer (>= 2.24.3-0ubuntu1) but it is not installable or
                          totem-xine (>= 2.24.3-0ubuntu1) but it is not installable
  totem-plugins: Depends: totem-gstreamer (= 2.24.3-0ubuntu1) but it is not installable or
                          totem-xine (= 2.24.3-0ubuntu1) but it is not installable
                 Depends: python-rdflib but it is not installed
  ubuntu-docs: Depends: gnome-user-guide but it is not installed
               Depends: yelp but it is not installed
  upstart: Depends: mountall but it is not installed
  upstart-logd: Depends: upstart (= 0.3.9-8) but 1.5-0ubuntu5 is installed
  x11-apps: Depends: cpp but it is not installed
  x11-session-utils: Depends: cpp but it is not installed
  x11-utils: Depends: cpp but it is not installed
  x11-xkb-utils: Depends: cpp but it is not installed
  x11-xserver-utils: Depends: cpp but it is not installed
  xinit: Depends: cpp but it is not installed
  xulrunner-1.9: Depends: python2.5 (>= 2.5) but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.