Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I restarted my computer, and when I logged back in, I noticed that all of my files that were on the desktop are gone. Instead, icons of all of my home folder are showed on my desktop.

I opened the terminal and found out that there is no ~/Desktop folder.

What happened? What do I need to do?

12.04 32-bit WUBI installed.

share|improve this question
Lets do a search and hope it's there somewhere. Open a terminal window and type "find Desktop" without the quotes. If that doesn't work, try the following: "find | grep desktop" which will certainly produce some output but you'll have to look at it carefully to see if your files are there. If that still doesn't work we might have to start searching the whole hard drive. – fabricator4 Sep 16 '12 at 5:23
You could also do a search for one of the files that are missing if you can remember the exact filename eg: "find". If you cant't remember all of the filename use as much of the filename as you are certain of and use asterisk wildcards for the rest eg *ourfile.* – fabricator4 Sep 16 '12 at 5:27
Yesterday my ~/Trash folder disappeared and a directory in ~/.local/share. Reason unknown. Version: Daily updated Ubuntu 12.04 LTE (not WUBI). – guettli Nov 30 '12 at 9:14

You need to edit the ~/.config/user-dirs.dirs file. Make sure the contents of the file are like the following:


Then restart nautilus:

killall nautilus


nautilus -q

Then, open nautilus via Unity menu (press the Super key) or using the run command (Alt+F2)

share|improve this answer
Thanks! That did it. It happened to me last night after a system update. Seems to be widespread. Any idea what caused it? – Jorge M. Treviño Oct 5 '12 at 18:40
Thanks for your solution too! My problem is a bit different: all folders and files on the desktop disappear, but files on home aren't showed either. Just mark down for others with the same problem as mine. – Xu Jiawan Jul 30 '13 at 2:16
@XuJiawan It's good to know that the solution solved the problem. However, if the problem was different it'd be better if you ask a new question and I'd post the solution there. This is because it is preferred to have one question per thread, even when the solutions are same. – green Jul 30 '13 at 7:34
@green7 Thanks for your suggestion. I've posted my problem here with your solution. ^_^ – Xu Jiawan Aug 2 '13 at 2:56

I faced the same issue yesterday and the following commands did the trick;

gconftool-2 --recursive-unset /apps/compiz-1

unity --reset &

But mine is a general install, not through WUBI.

share|improve this answer

I was also having similar issues. What I see went wrong is my $HOME variable is pointing to /tmp instead of /home/username.

share|improve this answer
that's way too weird... – Braiam Sep 1 '13 at 21:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.