Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using CrashPlan I've configured two backup sets:

  1. online backup in crashplan's cloud (this is running perfectly)
  2. a local backup on a usb harddisc directly connected to the local laptop.

The USB drive is only connected rarly when being at home. When connecting the drive it mounts automatically. Is there a way to start the local backup whenever the usb disc connected.

My guess is that using udev it should be possible to "somehow" tell crashplan to reevaluate the presence of backup location. Any ideas to do this?

share|improve this question
    
I also ran into the problem of CrashPlan filling up the root drive when it's supposed to be writing to an external drive. Their support told me to backup to a subfolder on the drive (not at the root), but it didn't fix the problem for me. –  endolith Nov 20 '12 at 18:26
add comment

1 Answer 1

up vote 2 down vote accepted

No,

the CrashPlan client does not offer this basic level of functionality. I had a similar problem and I can confirm that it is not possible, according to tech support at CrashPlan. They are either unable or unwilling to support it, instead referring paying customers to the forums for help. Here is the email I sent explaining a very similar situation, along with their response:

Me

Crashplan, May 22 09:49 am (CDT):

Ubuntu Linux 12.04 64-bit, fresh install.
Root filesystem '/' is on a small SSD
Home filesystem '/home' is on a large HDD
Backup drive is on a third HDD.
First drive automatically mounts at BOOT, next two drives automatically mount at LOGIN.
CrashPlan starts at boot, before I login, so it creates a directory in the small Root drive, which quickly fills up. I need to clear all those files out, and then set CrashPlan to wait for the HDDs to mount before it writes any files to backup.

Crashplan's response

Jason S., May 23 11:17 am (CDT):

Hello,

Unfortunately, CrashPlan is specifically designed to launch at startup, at the runlevel that it is assigned. While it may be possible to disable that functionality and cause it to start manually, that's not something I would be able to assist with as it is not a supported configuration.

Here is a link to the forums:

https://crashplan.zendesk.com/forums/

Our user base has come up with means to assist each other with several unsupported configurations. I would suggest that you inquire further on the forums.

Let me know if there is anything else I can help you with.

~Jason

I was quite surprised to see CrashPlan creating a new directory at root, then blindly filling the disk until it created a bigger problem. It's my opinion that the software is poorly written and is not suitable for use until this is corrected. Déjà Dup will check that the destination drive is connected and has space, which is the correct approach. CrashPlan gives no error messages and creates new problems.

I recommend using Déjà Dup combined with Ubuntu One instead. It actually works, and does not create any new problems. It can cost more if you have lots of data to back up, but you get what you pay for.

share|improve this answer
    
so the only option would be a "/etc/init.d/crashplan restart" triggered by udev when pluging the device. And lock down the parent folder of the backup location not to permit creating directories to prevent backups being done on the wrong filesystem. –  Stefan Armbruster Sep 1 '12 at 9:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.