Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently downloaded Minecraft with the .jar format and had it running on my computer not so long ago. Now that I'm using my desktop instead of laptop temporarily, I want it to run. On my laptop it was a tremendous hassle to get OpenJDK to even run the application without it going black and I don't have that problem on my desktop.

However, when I run the application on desktop, my keyboard becomes unresponsive and doesn't type at all. This is a really big problem because I can't play the game as it requires keyboard interaction. It works as normal on my laptop though and it works perfectly. But now on the desktop it's completely useless.

I don't know if there's like a keyboard driver I'm missing, but there shouldn't be because the keyboard runs flawlessly everywhere else. I'm using OpenJDK 6 because the 7 has the same 'black screen' I mentioned. So I need this to work within OpenJDK 6.

Thanks so much in advance and I'll try to specify as many details as I can.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

On the download page for Minecraft, Mojang states to:

please use Sun's JVM.

You can find instructions on how to do this here. You don't need to bother with any section other than "Choosing your JRE" unless you want to.

Mojang didn't design Minecraft to run on OpenJDK, they instead designed it to run on Sun's Java. These incompatibilities were what were causing your keyboard to become unresponsive.

share|improve this answer
    
I have tried multiple times but no avail. In the end running the command with sudo enabled all features and all is now fine. Cheers. –  Mochan Oct 1 '12 at 7:13

This may be a problem with the Lightweight Java Game Library (lwjgl). Mojang does not keep up with their updates. Download the latest version from http://lwjgl.org/download.php, and extract the archive. Replace jinput.jar, lwjgl.jar, and lwjgl_util.jar in the .minecraft/bin directory with the corresponding files from the extracted directory lwjgl-2.8.x/jar. Also replace the the files in .minecraft/bin/natives with the files from lwjgl-2.8.x/jar/native/linux. Just to be safe, you should probably make backups of those files before you replace them.

Hope this works!

share|improve this answer
    
Very interesting! I'll try this and get back to you. –  Mochan Dec 4 '12 at 21:04

I'm not sure about using openjdk with minecraft, but I will say that having the ibus daemon running while playing minecraft with oracle-java6 yields the same result.

Try disabling/quitting ibus then playing.

share|improve this answer
    
That did contribute to the problem. Thanks for noticing :) –  Mochan Jul 2 '13 at 7:41
1  
Easiest way to get Minecraft running on ubuntu: sudo add-apt-repository ppa:minecraft-installer-peeps/minecraft-installer sudo apt-get update sudo apt-get install minecraft-installer –  The NetZ Jul 3 '13 at 15:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.