Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm relatively new to Ubuntu, and am running into a problem I've not seen before. This is on an Ubuntu 12.04 system. I can't find Screenshot. I'm trying to take a shot of a screen from a web page, go to Dash, type in Screenshot, and nothing shows up. I've done this many times before, but suddenly Screenshot is not found.

I downloaded an app called Shutter, it seems to have installed just fine, but like Screenshot, I don't know how to find it. Dash reveals nothing. In Dash, I've noticed that I have no applications showing up in response to a search. For instance, I can type Firefox, and get no results either, even though I'm using Firefox to submit this question. Is there something I can do to get Dash to show applications? Search results show only files and folders, and downloads.

I did find one answer on Ask Ubuntu, which gave the following instructions: None of these fixes worked for me. But after more searching:

rm ~/.cache/software-center -R

worked like a charm. I did need to run:

unity --reset &

afterwards though, for the changes to take effect within dash, but the software center just started working straightaway.

However, when I issued the unity --reset & command, it resulted in an internal error, and I'll have to reboot in order to reset my computer (which fortunately is allowing me to complete this question).

So I'm still wondering why applications won't show in Dash, and will appreciate any help.

share|improve this question
    
Did you upgrade from 11.04 or is this a fresh install? –  jokerdino Sep 1 '12 at 1:13
    
Try searching in application lens. Application lens is right after the home lens. Lenses are the bottom bar in dash. Home lens is selected by default (has a little triangle on top of its icon) –  Aleksandar Sep 1 '12 at 10:28
    
Thanks Aleksandar. I upgraded from 11.04. I've also tried the different lenses, and selecting the application lens doesn't help. Still shows nothing when I search for screenshot (or other applications). Actually, I was able to see applications for a short time yesterday after rebooting. The sequence I went through was: Rebooted. Opened Dash. Unable to see Screenshot. Did some other work. Tried Dash again, Screenshot was there. Used it to capture an image from a web page. Shut machine down. Rebooted again today, searched Screenshot, but no applications, only files and downloads. –  Bruce Sep 2 '12 at 1:50
    
Thanks jokerdino. As I mentioned in my previous comment, I'm currently running 12.04 as an upgrade from 11.04. Today, Dash is working fine. Seems inconsistent. Sometimes I see my applications in Dash, sometimes not. If not, is there another way I can start an application? –  Bruce Sep 3 '12 at 1:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.