Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've built a new system, and I want to take full advantage of UEFI and Ubuntu. So I install Ubuntu, and try to boot from it, and my BIOS (Asus EZ Mode / Advanced Mode) simply says "No bootable medium found. Insert Bootable Medium and press any key to try again." So I've reinstalled several times, without any failures, Ubuntu IS installed, and I've tried Ubuntu Boot Repair (link below) and nothing I do seems to work.

My Build:

Asus f1a75m pro

AMD A8 APU

Samsung 1TB HDD

8GB G-Skill Ripjaws X (1866)

Partitions and Ubuntu Boot Repair

here

share|improve this question

closed as too localized by fossfreedom Oct 5 '12 at 23:24

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

2 Answers 2

Your problem seems very similar to mine - A8 in ASUS F1A75Vpro with built in graphics. Failed to boot fully until about the 5th reset, sometimes consecutive 10th. Always started to boot, usually freezing when 5 red dots have appeared beneath ubuntu. But eventually it gets through. I then changed the /etc/default/grub to remove the spash/quiet so I could see where it got to (you don't get the ubuntu and dots), and ran update-grub. Same problem, but it always seemed to finish but freeze at the last minute before presenting the gui. So I then put in the linux parameter nomodeset and so far it is booting cleanly every time (except that I can't get unity 3D and only have 2D - but that's no matter).

You could try the same if you sometimes do manage to get in.

I know nothing of boot repair, but don't like the look of what it has done. It seems to have deleted grub-efi-amd64 and put in grub-efi-ia32-bin, and put a lot of stuff in /mnt. My /mnt is empty and I still have the amd64. Maybe you should wipe clean and start again.

share|improve this answer
    
Actually my MOBO died do to various issues, so I don't have to worry about it now... –  John Oct 5 '12 at 20:15
add comment

Your Ubuntu is correctly setup in EFI mode.

  1. First check that your EFI firmware (BIOS) is setup to boot your HDD in EFI mode.

  2. If still not good, make your EFI firmware boot your HDD in Legacy (non-EFI) mode. Then convert your installed Ubuntu in Legacy mode: run Boot-Repair from liveCD, click Advanced options, go to the GRUB location tab, untick the Separate /boot/efi option, click Apply. Then reboot.

share|improve this answer
    
1. My BIOS is setup to boot HDD in EFI mode, I just checked that –  John Sep 1 '12 at 3:49
    
2. From what I read you're telling me to setup Ubuntu in non-EFI mode, and just use that. I really want/need to use UEFI, so that doesn't fix the problem. –  John Sep 1 '12 at 3:50
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.