Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have problems with my resolution and I wanted to adjust it with the help of xrandr, but when I try to set it up it changes the values..

fabio@fabio-EasyNote-TS11HR ~ $ cvt 1366 768
# 1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
Modeline "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync

so it changes my 1366 in 1368 and when i try xrandr:

fabio@fabio-EasyNote-TS11HR ~ $ xrandr --newmode "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
xrandr: Failed to get size of gamma for output default
X Error of failed request:  BadName (named color or font does not exist)
Major opcode of failed request:  149 (RANDR)
Minor opcode of failed request:  16 (RRCreateMode)
Serial number of failed request:  19
Current serial number in output stream:  19

What can I do?

share|improve this question
add comment

1 Answer

Same problem here ... I'm using dell xps14z

I got it partially working with 1360x768 and to make the changes permanent I added this lines to .profile hidden file like this:

gksu gedit ~/.profile

then at the end of the file I added:

xrandr --newmode "1360x768_60.00"   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync
xrandr --addmode LVDS1 1360x768_60.00

when I reboot I still get 640x480 in the login screen but after successful login I get 1360x768

Just to mention it: I got into this problem after trying to enable Unity 3D which I got using bumblebee

share|improve this answer
1  
To run a graphical application like gedit as root, you should use gksu/gksudo instead of sudo, as running gedit directly with sudo can prevent it from working correctly when run as the limited (non-root) user. –  Eliah Kagan Oct 1 '12 at 1:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.