Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to write in terminal in devnagari script, the vowels are shown separated from consonants (unlike how it is written).

The same is the case when I open a file containing devnagari characters in vim in terminal.

Is there a way to get these characters printed properly?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

You may be out of luck. Even though Devnagari (Hindi, etc.) script works well in most text input areas like gedit, browsers, and word processors, it looks like complex indic scripts like Devnagari are not supported in the default gnome terminal. However, some people were working on Devanagari support on GNOME Terminal and the results are available here.

I have no idea how this tweaked version of gnome terminal will fit into Ubuntu. As usual use caution when installing programs, apps and codes from unknown sources.

Another option is to install fbterm from Ubuntu Software Center. See the comments section of How can I get colors in TTY working correctly? for how to make it work.

Hope this helps

share|improve this answer
    
OK. Are there any terminals in the distros that support rendering of complex scripts like devnagari? –  deshmukh Sep 3 '12 at 10:31
    
I have added fbterm to the answer. Let me know if you can get it to work. –  user68186 Sep 3 '12 at 17:55
    
Nope. I am not able to start fbterm from Unity. –  deshmukh Sep 9 '12 at 12:54
    
Try: add yourself to the video group. Then you should be able to start fbterm from terminal. –  user68186 Sep 9 '12 at 12:59
    
No. Does not work. Gives an error 'stdin isn't a interactive tty!' –  deshmukh Sep 9 '12 at 13:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.