Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 10.10 on a Revo r3610 nettop with integrated sound (Intel HDA) and graphics (nVidia ION).

When I boot up with the monitor turned on everything works fine. If I then turn off the monitor sound continues to work as normal. However if I boot up with the monitor turned off, I cannot play sound. When I turn on the monitor, it just suspends itself without displaying a picture. If I VNC to the box, the sound icon in the tray shows as muted (three dashes) and nothing is shown in the hardware sound devices panel. The sound card still shows up in an lspci listing though.

The monitor is connected via HDMI and the sound is via 3.5mm headphone jack to an external amp. The monitor also has integrated speakers but these are not in use.

Edit: I've also noticed that the computer only goes to sleep/suspend when it was booted up with the monitor plugged in. Otherwise it stays on all the time. It seems that some part of gnome is not being started properly when it can't find the monitor.

share|improve this question

2 Answers 2

I am inclined to suspect that there is some kind of issue with the audio drivers. Since you are not using the HDMI audio device, I would suggest disabling it in the BIOS if the option is available.

share|improve this answer
    
I've checked the BIOS and there's no option to disable HDMI sound, only onboard sound. See also edit above about suspend. –  Tamlyn Dec 22 '10 at 10:45
    
Sounds like the onboard sound is integrated to the HDMI output. You could buy a HDMI to DVI/audio splitter I think, which might work, if such a thing exists. –  djangofan Jan 4 '11 at 22:10
    
gefen.com/kvm/dproduct.jsp?prod_id=3939 . of course, it requires that your monitor also have a DVI port. –  djangofan Jan 4 '11 at 22:11

It sounds like the Revo is saying, no monitor? Oh then I must be a server, so nobody will hear me scream. I might as well turn off audio then, and turn off graphics of course. Pout.

This would be a (hardware?) issue with the Revo itself, not with Ubuntu, so the only real solution would be to turn on the monitor before the Revo, or at least at the same time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.