Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 2x 2.1 speakers connected to the computer where I have Ubuntu 12.04 installed. On the software side I've set all the volume controls to 100% with the alsamixer program.

The speakers have their own volume control, maintaining those at the same level, and switching between Ubuntu and Windows (XP and 7), on windows the output volume is at least 40% higher, even when having the windows volume control at 50% (without touching the speakers volume control) it's still much higher than the sound on Ubuntu.

Why can this be happening?

Are there some alternative sound drivers (other than the default ones) I could test to see if it makes a difference?

some info about the card:

root:$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xfbff4000 irq 55
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfbcfc000 irq 56

root:$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
02:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cayman/Antilles HDMI Audio [Radeon HD 6900 Series]

I think the one i am using is the Intel one, the other seems to be from the vga card which is an ati radeon 6950.

Running gstreamer-properties and switching between alsa, oss, ossv4 and pulseaudio doesn't seem to make any difference.

share|improve this question

2 Answers 2

I don't know if this will help you, but on my system (a Thinkpad T510) I have to open up the sound control panel (right-click on the sound icon in the notification panel and select "Sound settings...") and move the volume bar to 140% (or so, it doesn't actually change the displayed number) to get full volume. I don't know why this is and it's quite irritating since the volume keys on the laptop will only go up to 100% and I have to open the control panel several times a day to be able to hear anything. Just like in your case, this is not a problem with Windows where 100% really does mean 100% of the available hardware volume.

share|improve this answer
    
Yes I also did that a few times, but as you said, as soon as i use the keyboard to change the volume that gets reset. But, having the slider on "Sound settings" to the max (>100%) gives me still much lower volume than in Windows. –  ncomx Aug 31 '12 at 2:37

Open a terminal and try this command:

alsamixer 

This will open the ALSA mixer application, which should allow you to be able to increase the level of master volume sound.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.