Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Skype on 12.04 x64 does not start even after purging and reinstalling it

I've tried many different ways:

I downloaded the file from the Skype website, which returned this error Cannot install ia-32-libs.

I followed these instructions and here is what I got:

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/precise/partner/Packages/binary-amd64/Packages  404  Not Found [IP: 91.189.92.191 80]
W: Failed to fetch http://archive.canonical.com/ubuntu/dists/precise/partner/Packages/binary-i386/Packages  404  Not Found [IP: 91.189.92.191 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

I even tried this command line:

sudo apt-get install lib32stdc++6 lib32asound2 ia32-libs libc6-i386 lib32gcc1 skype

And this is what I got:

Error: need a repository as argument
pandora@ubuntu:~$ sudo apt-get install lib32stdc++6 lib32asound2 ia32-libs libc6-i386 lib32gcc1 skype
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch
 skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

I just don't know what to do anymore, if I can't use Skype, I might as well not use Ubuntu at all.

Please, someone help.

share|improve this question

marked as duplicate by jokerdino, hhlp, Jorge Castro, Mik, Stephen Myall Nov 22 '12 at 21:12

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
There is something wrong with your repository setup. For example, the partner URL should b: archive.canonical.com/ubuntu/dists/precise/partner/binary-amd64/… Please regenerate your repository list using repogen.simplylinux.ch and then save it as /etc/apt/sources.list. Then update and try again. –  izx Sep 26 '12 at 23:40
    
try this sudo apt-get install -f –  Maduka Jayalath Nov 17 '12 at 8:09
add comment

1 Answer 1

You do not have to download Skype from the website.

Have a look at: https://help.ubuntu.com/community/Skype

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.