Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Running Ubuntu 12.04 Unity with kernel 3.4.0-030400-generic on a laptop, when I lock with ctrl + alt + L and close the lid, then open the lid, I expect to see a prompt asking for password, but instead all that is visible is the current desktop background, and mouse cursor. This happens immediately after lid is closed and opened. Suspend on lid close is off.

When moving mouse around the middle of the screen, it changes shape as if there was a textbox under it (the password prompt), implying there is something there, just not rendered.

I can ctrl + alt + F1 to tty and restart the laptop, but, shockingly, it is annoying. I have have also had some random freezing problems, but those seemed to end when I updated from kernel 3.2 to 3.4.

Laptop is Asus A75VM-TY167V, has Nvidia Geforce 630m and radeon HD4000. I am using Bumblebee.

Googling only brings up issues with freezing, suspending, and black screens, so this seems a fairly rare problem. Any ideas?

edit: Appears to be a known bug and closely related to black screens. https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/966744 I guess this can be closed.

share|improve this question

closed as off topic by Marco Ceppi Aug 30 '12 at 19:52

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.