Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a linux newbie looking for some help.

I'm currently setting up an XBMC HTPC using a laptop and 10.10 and all works great except for waking from resume using the power button on the remote. The suspend works from remote works fine as does the resume using the power button on the laptop.

I've checked /proc/acpi/wakeup which initially showed the following.

Device  S-state   Status   Sysfs node
C096      S5    *disabled  pci:0000:00:1e.0
C0F1      S3    *disabled  pci:0000:00:1d.0
C0F8      S3    *disabled  pci:0000:00:1d.1
C0F9      S3    *disabled  pci:0000:00:1d.2
C0FA      S3    *disabled  pci:0000:00:1d.3
C0FB      S3    *disabled  pci:0000:00:1d.7
C102      S5    *disabled  pci:0000:00:1c.0
C22B      S5    *disabled  pci:0000:08:00.0
C115      S5    *disabled  pci:0000:00:1c.2
C22C      S5    *disabled  
C118      S5    *disabled  pci:0000:00:1c.3
C22C      S5    *disabled

I've since configured the above so that the S3 devices above are enabled. I've confirmed that they are the correct devices using lspci

00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)

None of this has worked unfortunately and I'm now stuck. It simply refuses to wakeup from the remote. The USB receiver shows no activity LED while suspended. Suspend/resume from the remote works fine from Windows 7 so I know the laptop is ok with it.

Any ideas? I need to get this sorted to gain Wife Approval for this system.

Thanks, Bod.

share|improve this question
    
It might be useful to provide laptop model and usb remote model, so that the google fairies have something to work with :-) My gut feeling is that the hardware might need a bios upgrade (bios is often windows friendly, but doesn't do the standard thing) –  finley Dec 21 '10 at 8:42
    
Thanks for the response. It's a HP NC6320 laptop with latest available BIOS update. The remote is a Microsoft Windows MCE Remote which shows in lsusb as a Philips (or NXP) eHome Infrared Receiver. –  Bod Dec 24 '10 at 8:06
add comment

1 Answer 1

up vote 0 down vote accepted

Right! Problem solved - I found the solution here http://forum.xbmc.org/showpost.php?p=658293&postcount=168

To summarise, I noted the vendor and product id from lsusb then created the file /etc/udev/rules.d/90-mcewakeup.rules and populated it with

SUBSYSTEM=="usb", ATTRS{idVendor}=="0471", ATTRS{idProduct}=="0815" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'"

note that you'll need to substitute the vendor and product ids as reported on your system.

In addition to this I found that I also needed to edit the line beginning with GRUB_CMDLINE_LINUX_DEFAULT= in /etc/default/grub as follows

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash xbmc=autostart,noredir usbcore.autosuspend=-1"

followed by update-grub to finish off.

After all this I now have a system that can wake from my USB remote. :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.