Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I like to switch sometimes between Lubuntu and Ubuntu 2D on my laptop. But I especially like to choose which one I will use in the session I am about to start. But the only way of choosing is start the laptop up, and the last used thing will show up (as it should), then log out completely, and choose the other thing from the login menu.

I have spent a lot of my lifetime using Windows, and always I was asked a login BEFORE I actually could do anything. Now I think it is weird that anyone can log into a password-protected account without giving any passwords, as long as the last user was the Admin. Also: will logging out before shutdown help?

Here is my default.conf file.

share|improve this question
1  
Can you paste the contents of default.conf to paste.ubuntu.com instead of taking a screenshot? Be sure to give a link. –  hexafraction Aug 30 '12 at 18:52

2 Answers 2

up vote 4 down vote accepted

Try this. To disable autologin, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo leafpad /etc/lxdm/default.conf

In the fist few line, you will see something like autologin=username change it to the original state of # autologin=dgod. Save the file, and then reboot your machine.

Also try to go to System Settings --> Users and Groups, click on change next to Password

enter image description here

Make sure that the box is unchecked next to Don't ask for password on login enter image description here

Try to edit sudo leafpad /etc/lightdm/lightdm.conf with these contents:

Remove or comment out the following lines

autologin-user=username
autologin-user-timeout=0

For 14.04 everything works. The /etc/lightdm/lightdm.conf doesn't exist in 14.04, but the other ways work. See image below:

enter image description here

enter image description here

share|improve this answer
    
Tried it 3 times (Lubuntu: old hardware => massive startup time) and no difference at all. The file saved correctly as it is still changed to what you said. Maybe there is another setting that still has to be adjusted? –  nathan Aug 30 '12 at 17:35
    
Can you include the output of your default.conf file? –  Mitch Aug 30 '12 at 18:21
    
these are the first lines of it: @Mitch [base] ## uncomment and set autologin username to enable autologin # autologin=dgod ## uncomment and set timeout to enable timeout autologin, ## the value should >=5 # timeout=10 ## default session or desktop used when no systemwide config session=/usr/bin/startlubuntu ## uncomment and set to set numlock on your keyboard # numlock=0 –  nathan Aug 30 '12 at 18:24
    
I don't know how to do the grey box thing nor how to start new lines without sending the comment in... I'm really sorry. –  nathan Aug 30 '12 at 18:31
    
No need to be sorry. What Lubuntu release are you running? –  Mitch Aug 30 '12 at 18:34

So I am using a Lubuntu 14.04.1 LTS installed on a USB stick. And this is how I managed to disable auto loging for Live Session User.

  1. Create e new user (to use for loging): System Tools -> Users and Groups

  2. Open console: System Tools -> XTerm

  3. enter command:

    sudo leafpad /etc/lightdm/lightdm.conf
    

    the text editor should apear

  4. replace line:

    autologin-user=lubuntu
    

    with

    autologin-user=name_of_user_you_created
    

    optional you could change line

    autologin-user-timeout=0
    

    to

    autologin-user-timeout=60"
    
  5. save and close file

  6. reboot

for more info access: https://wiki.ubuntu.com/LightDM

After power up you should see the login screen with the user you created waiting for password.

Atention: user "lubuntu" is still there but is not presented in the dropdown list. if you want to access it you need to chose other then insert user name by hand. Also leave blank for password as user lubuntu does not have a password by deault.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.