Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried a dualboot (Win7 + Ubuntu) installation it on a Lenovo E330 with Agility3 240 Gigs...

  1. Ubuntu::
    Ubuntu 12.04 x86_64 ( 21.06.2012 ) is not able to install grub in a bootable way. Grub will be installed and does update-grub during Installation, recognizes also the Win OS. But after a restart it boots directly to Windows.
    This is directly connected to the OCZ Agility3. On a good old fashion harddisk (those with the moving parts) Ubuntu is capable to install grub with no problem in a bootable manner.

  2. PinguyOS::
    PinguyOS 12.04 LTS x86_64 (which is a Ubuntu based distro) is able to handle the Grub installation on OCZ Agility3. However they both use Grub 1.99...

  3. What i did::
    Installed Windows. Installed Ubuntu. Installed PinguyOS.

  4. Grub Updates::
    Grub updates are only through Pinguy OS possible, this means you have to edit the Ubuntu Grub entries manually after Kernelupdates on Ubuntu, in the PiguyOS sytem..

What i've already tried:

  • Firmwareupgrade OCZ (livestick, successfull)
  • Install Ubuntu Grub to sda
  • Install Ubuntu Grub to sdc (Ubuntu Partion)
  • Install Ubuntu Grub to /boot
  • update-grub manually after install
  • restore grub

any ideas appreciated..

share|improve this question

I resolved the issue by running a live USB and fixed Grub with boot-repair:

  • Boot any Ubuntu live USB
  • Connect to internet
  • Open terminal by hitting Ctrl+Alt+T and run following commads:

    sudo su

    You are root now...

    add-apt-repository ppa:yannubuntu/boot-repair
    apt-get update && apt-get install boot-repair -y
  • Keep terminal open (you will need it in root mode)

  • Start boot-repair by typing boot-repair
  • Follow boot repair advises, make sure to enter the commands WITHOUT sudo (cause you are already root
share|improve this answer

I just struggled with e330 + Kubuntu 12.04 LTS. It just kept booting to Windows 7.

To solve this I realised that because e330 supports uefi the installation had detected that and chosen packages for grub as grub-efi-amd64-bin grub-efi grub-efi-amd64. Installing grub-pc resolved the issue (After running grub-install, update-grub etc stuff). Typos notwithstanding this is basically what fixed it for me when I booted up the system with rescuecd.

sudo apt-get install grub-pc
sudo grub-install /dev/sda
sudo update-grub

P.S. When using the Ubuntu install CD rescue option you might not have networking because the resolv.conf file is absent. To create one temporarily I think it's enough to do

mkdir /run/resolvconf ; echo "nameserver" > /etc/resolv.conf

assuming that /etc/resolv.conf is a symlink to ../run/resolvconf/resolv.conf.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.