Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having 9GB text file which is encrypted .

This file contains some confidential data . Which is on my system(Ubuntu) and my external HDD (ntfs) . This file get daily updated and then encrypted . But it has to be shared among 2-3 (Windows) person. I defined permission so that no other person can even read this file(chmod 660). It is too large file, so I can't upload it anywhere and it get updated daily basis.

But this file travel on Windows OS and Ubuntu also. Even I am having copy of this on my personal computer. Recently it was deleted by some other user over Windows . I just want to know how can I set permission over that file so that it cannot be deleted from any other operating system. If someone delete this file, then I am having data old for couple of days, which is only on my system.

I gone through this question it says there is nothing.
And from this question I am not able to understand how can I protect it.

Can I do anything for preventing this file from being deleted.

Then how can I secure this files from getting deleted any suggestion or software or ideas.

Maybe I sound silly or this is stupid question. Please don't close it, thanks for any suggestion or solution.

share|improve this question
1  
I think it is not possible for usb disk that is travelling across different computers and different OS where the user can be an administrator. A way could be partition your disk, encrypt a partition that holds the file. –  Web-E Aug 30 '12 at 15:17
    
Yes, as @Web-E said, when you transfer file with USB you can't enforce settings. This is more true with FAT partitions. Because, An administrator in every OS has almost absolute right on the USB devices at least –  Anwar Shah Aug 30 '12 at 15:23
    
You will most likely need to set some permissions on windows. One thing you could do is create a protected folder in windows, so only you can delete it, but other certain people have read access. Then when your update your file, drop it in that folder. No-one will accidentally delete it, because no-one has permissions. –  Jobi Carter Aug 30 '12 at 15:28
    
@JobiCarter a protected folder in one windows system won't persist in other systems. –  Web-E Aug 30 '12 at 15:46
    
I presume that you are using SAMBA to share the file with windows users, so the permissions applied to the file on the Linux side are translated into windows permissions by samba. Think you need to look at the shareing directive that you are useing in samba, and what file permissions these users have through samba, look at /etc/samba/smb.conf here you can either set the share to read only = yes or set create mask = 0600 this means that the permissions that external users have are filtered through the mask, in this case read and execute user permissions only. –  Stuart Aug 30 '12 at 16:20

1 Answer 1

NTFS supports permissions, you just need to tell Ubuntu where and how to enable them via the /etc/fstab file.

Follow bodhi.zazen's instructions in your second link (the one answered Dec 28 '11 at 16:31). Those instructions tell Ubuntu to automatically mount the external drive using the options from the fstab file. Once you do that, and remount the drive, your chmod will work.

share|improve this answer
    
If you're satisfied that your question has been answered, could you please also accept the answer so that the question is marked as 'answered'. –  Tom Sep 14 '12 at 15:34
    
Doesn't answer the question though - this will not protect it once it is on a USB key or another windows machine... –  Rory Alsop Oct 30 '12 at 15:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.