Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a two weeks old SSD (Kingston SSDnow 64GB). Yesterday, the computer shutdown twice and after rebooting I was bombarded with disk failure warnings.

I usually take such warnings serious (and backed up), but skeptical. After cooling down, the laptop boots again and the only red Smart value was the temperature (Ubuntu did not show the temperature of failure, but the at that time 29°). After refreshing the Smart status and doing a "self test", everything is green.

Before contacting Kingston support, I would like to know whether it could be due to a software issue:

  • Is it possible that it is false alarm, and how can I check?
  • I installed Ubuntu 12.04 32bit and took care of alignment. I supposed Ubuntu set up with optimal settings for SSDs, how can I check that there was no mistake?
  • The current temperature is around 40-56°. Is such a temperature abnormal for SSDs?

Output of sudo smartctl --all /dev/sda: pastebin link expired.

share|improve this question
up vote 4 down vote accepted

It does only seem to be temperature that's causing the issue here and here are a few things to mention:

  • The upper operational limit for this SSD appears to be 75°C.
  • SMART is reporting a threshold of just 30°C.
  • SMART can often be completely incorrect.
  • In my experience (with other brands of SSD) this is a fairly standard temperature.

That might sound like I'm saying it's all okay, but if it's pumping out errors, you might want to test it further. Sounds pathetic but I'd probably want to attach it to a Windows machine to see its SMART output there.

At least if it is only 180 hours old, you're almost certainly within the warranty :)

share|improve this answer
It seems the system started swapping heavily although RAM was half empty which caused the temperature to rise. I got it under control by disabling swap (or at least setting swappiness to 0): – Aegluin Sep 6 '12 at 20:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.