Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As far as I know, in older versions of XFCE this was a default behaviour - "Applications" menu was popped-up immediately on desktop mouse right-click. But now "Applications" menu appears as a sub-menu in a folder-class context menu which pops up instead.

I never store any files on the Desktop, so "Create folder", "Open terminal here" menu items are useless for me to have on the Desktop, instead I'd like "Applications" menu to open when I right-click on the Desktop.

From using ArchLinux I can remember that there was a special package to install to address this issue. Is there such a package (or another solution) available for Xubuntu?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

You have to disable all desktop icons in the Desktop configuration dialog in the Icons section. This will make the Application menu your right-click menu.

Unfortunately you can't have both.

share|improve this answer
    
That was one the first things I've done after installation - I don't use any desktop icons. But as I can see now, it was not enough to uncheck icons' checkboxes - after I also set "Icon type" to none, the problem was solved. –  Ivan Dec 20 '10 at 13:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.