Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Ubuntu 10.10 onto my laptop. Everything is working great however USB devices such as thumb drives and external hard drives wont show up. I have been looking around a bit and when I run sudo fdisk -l it displays this:

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00065684

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       29255   234983424   83  Linux
/dev/sda2           29255       30402     9212929    5  Extended
/dev/sda5           29255       30402     9212928   82  Linux swap / Solaris

Disk /dev/sdb: 16.0 GB, 16026435072 bytes
64 heads, 32 sectors/track, 15283 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000df90d

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1       15283    15649776    7  HPFS/NTFS

It does seem to display my 16 gig thumb drive but other then seeing it here I cant access it to read and write files to it. It does the same with my external hard drive. I know those devices work as I have tried them on my other computer and they are working fine.

Also this is what is in fstab if this will help anyone:

proc            /proc           proc    nodev,noexec,nosuid 0       0

/dev/sdb1       /               ext4    errors=remount-ro   0       1

/dev/sdb5       none            swap    sw                  0       0
share|improve this question
have you tried manually mounting your drive? you can mount it using "sudo mount -t ntfs-3g /dev/sdb1 <some directory>" – binW Dec 20 '10 at 7:52

The fstab seems broken.

It seems to define mount points for sdb, while your main disk is sda.

A quick fix could be changing all the sdb in fstab for sda and restart. But it's just a quick hack, the real solution should be using uuids for your drivers. Names like sd* can be changed if the BIOS reports the drivers in different order, sometimes just booting with some external device connected can cause it.

share|improve this answer

I don't really want to be the guy know for contributing nothing to this website than "please file a bug" but in this case I think it's a good idea. You have quite a good understanding of that's going on and have provided quite a lot of information.

Not sure if this affects anyone else, but hopefully this will be useful to the bug squashers to get this issue sorted for everyone.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.