Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Samba onto Ubuntu 12.04 Server but I can't login as it says my password is incorrect but I am the only user so there are no other passwords.

I have tried changing the password through the terminal but nothing is working.

Any advice for a newbie is very much appreciated.

share|improve this question

3 Answers 3

This is how I resolved the issue.

from a terminal box type sudo smbpasswd -a <user name> you'll be asked for a password, use your normal one

then you'll be asked for a new "SMB" password... sync it with the usual one by typing in you password again then confirming it...

Shares were instantly accessible from Win7 using Ubuntu user name and password

share|improve this answer

What did you use to change your password? Samba does not automatically use your user password, your first have to add your user to samba with smbpasswd -a <user>

*from http://www.cyberciti.biz/faq/adding-a-user-to-a-samba-smb-share/

share|improve this answer
    
I opened the terminal and typed smbpasswd -a NAME –  Luke Aug 30 '12 at 11:27
    
i then added a password but i cant get it to work –  Luke Aug 30 '12 at 11:28

Did you setup your share properly? I didn't have mine right apparently.

I used these settings: http://ubuntuserverhelp.com/basic-samba-configuration/

share|improve this answer

protected by Community Apr 4 at 22:49

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.