Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a usb wimax modem. If I connect it at ubuntu 10.04 it has been detected and mounted as cd see here.

From there I got that it is "iso96660" type and device location is /dev/sr1.

But when I connect this usb modem in Ubuntu 12.04, it could not be mounted. So I have tried to find the file sr1 in this location /dev/ and could not found any-thing. But if disconnect and then re-connect the usb modem at this path /dev/, I saw a flickering of "sr1" named file for a certain time (1 sec) then it's dis-appear.

Can anyone guide me to connect it step-by-step in Ubuntu 12.04?

share|improve this question
    
Edit the question to add the output of lsusb and also the model and made of your wimax modem –  Anwar Shah Aug 30 '12 at 5:46

1 Answer 1

Newer USB modems specially Wimax modems use a feature called zero cd. When you first insert the device, it will act as a CDROM and the driver gets installed from that CDROM. On subsequent insertion, the modem first mounted as CDROM and then very quickly it switched to the Modem mode, when the system detects the available driver.

Quoting from Wikipedia Article:

When a device uses the ZeroCD method means that it behaves as a USB CD-ROM when first connected, with a virtual CD-ROM inserted with the Windows device drivers and related Cosmote control program. Once the Windows device drivers are installed, a special USB command is sent to the device to “switch” it to modem mod

The package which is responsible to do the switching to the proper mode in Ubuntu is usb-modeswitch. So, Ubuntu 12.04 successfully switched the modem from CDROM mode to modem mode, which is required to use that as a modem.

Then why 10.04 mounts that as CDROM?

I guess, the usb-modeswitch package installed on Ubuntu 10.04 was missing the proper switching configuration for your specific Modem. (Please note that, proper configuration is required to do switch, such as vendor_id, product_id etc.). So, it only mounts it as a CDROM and can't go further.

If you are interested to see the content of the Modem device in CDROM mode, you have to prevent switching. (I'll add more info on this topic, if I find them). But, if you want to use the device as Modem, I think, you need to setup a connection using your modem now as it is already detected as modem.

If you want to mount the CDROM mode of the modem

  1. First remove the USB Modem

  2. Use this command to prevent usb_modeswitch to automatically switch to Wimax mode upon insertion.

    sudo chmod -x /usr/sbin/usb_modeswitch
    
  3. Then remove the driver if already activated. For my device (it is ZTE AX226 from Banglalion) the driver is bcm_wimax. So, I removed it with command:

    sudo modprobe -r bcm_wimax
    

    The drive may not be the same as me, but You can see a list of drivers loaded by the OS with command lsmod.

  4. Then execute lsblk command to see the CDROM mode of the device and it's device name. Alternatively you can use Disk-utility tool. For me it is /dev/sr1.

  5. Then use udisks or Disk-utility to mount the device.

    udisks --mount /dev/sr1
    

    If will be mounted most probably in /media/disk folder.

  6. Do what you wanted to do with it.

  7. Then again re-enable the usb_modeswitch with this command: ( This step is important)

    sudo chmod +x /usr/sbin/usb_modeswitch
    
share|improve this answer
    
thanks for your reply. What you have describe i know that but again thanks to remind me.When i connect that modem in ubuntu 10.04 it's appear in that way. I want the same thing in ubuntu 12.04. So, how can i do that??? –  maz Aug 30 '12 at 20:27
    
@maz I've added instruction to mount the modem as CDROM also. Please check the answer –  Anwar Shah Aug 31 '12 at 4:49
    
many many thanks for your answer. Anwar i modem is "Qubee" provided "shuttle" modem. It's not linux compatible because it's pre-loaded with windows driver. Now came up with your instruction. At first in my ubuntu 12.04 there is no usb_modeswitch installed. Secondly no driver is installed. But i have use your "lsblk" command and got this out-put. –  maz Aug 31 '12 at 21:05
    
here is the out-put –  maz Aug 31 '12 at 21:17
    
from this out-put you can see there is no "sr1" device is present. When i connect the device in usb for a short period of time the file "sr1" could be found in "/dev" folder. And then vanish. I hope you can guide me to the right path. Thanks in advance –  maz Aug 31 '12 at 21:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.