Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I saw several similar threads, but none really does it...

I have 12.04 precise x64 installed and things worked great for some 10 days. Then it all stopped - I wasn't able to connect any more.

Even more, things were so scre*ed up that it were showing other network's name while connecting :(

I have an Asus K53SM-SX054. Here's the text from dmesg related to my card:

http://fixee.org/paste/iaw23iw/

Basically, it's Intel Centrino Wireless-N 1030.

Not sure if it's important, I had Gnome with unity and then moved to KDE.

Any ideas what to do? I'm on the verge of reinstalling things, but I already set plenty of things and have some things that I'd need to back up... and I'm rather lazy to go on with it :)

EDIT: My wlan network is hidden. Not sure if this should have any influence.

share|improve this question
    
I don't think this is intel specific. try deleting all wireless networks in network-manager and adding them again. –  hbdgaf Aug 29 '12 at 21:10
    
thx replying, but i tried this with no success... wireless is not broadcasting it's id (it's hidden)... –  playcat Aug 29 '12 at 21:19
1  
bugs are off-topic per the FAQ bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1002450 it seems you aren't the only one with the problem –  hbdgaf Aug 29 '12 at 21:22
add comment

1 Answer

up vote 0 down vote accepted

This bug has been showing up in various versions of KDE4 since 2009, and across many distributions (Debian, RedHat, and SuSE-based) as far as I can tell. There are a lot of janky solutions that involve manually running commands in the shell, editing config files by hand, etc. The KDE team has not paid much attention to it and has done things like marking it "medium" priority, saying nothing in response to it for months/years, etc. It's a thorn in the side of many KDE laptop users, unfortunately.

If you have access to your router, the easiest way to get around this is to temporarily enable SSID broadcasting. The network will show up - add it. Now turn off SSID broadcasting and reboot. It "should" pick it up.

If you DON'T have access to your router, try using wicd or the Gnome network manager (I forget what it's called.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.