Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to run the Minecraft demo game on Ubuntu I get to a screen that says
"Minecraft Updating"
"Done loading"
But it was never done loading. I am not sure if I am being impatient or there is something wrong because I have left the game to update and when I returned 15-20 min later nothing had happened. Please help I have been through many different forums and tried installing Oracle Java 7 which I removed for OpenJDK Java 7. I added the LWJGL package to the .minecraft folder and still nothing has happened.

Thanks ahead of time!

share|improve this question
    
Start minecraft from command line with java -jar minecraft.jar and note the error message. If the error message mentions lwjgl.so then use the solution from @Purplerob –  Sergey Aug 29 '12 at 21:16
add comment

3 Answers

Try running:

export LD_LIBRARY_PATH="/usr/lib/jvm/java-7-openjdk/jre/lib/amd64/"

before starting minecraft. The location might be different so you should hunt around in /usr/lib/jvm/[java folder]/ for a similar place.

I had this problem in arch and this solved it but because it was not ubuntu I'm guessing the location would be different.

share|improve this answer
add comment

For some reason minecraft has stopped working with Java7 you should install openJDK6 and use that. To do so you should run sudo apt-get install openjdk-6-jre. Once this is doen make sure that that is the java being used by running

java -version

which should print

java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.3) (6b24-1.11.3-1ubuntu0.12.04.1)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

if it does not display that then run:

sudo update-alternatives --config java

and select the /usr/lib/jvm/java-6-openjdk-amd64/jre/bin/java option.

Minecraft should work correctly after that.

(note if you are on a 32-bit machine replace amd64 with i386 and 64-Bit with 32-Bit)

share|improve this answer
add comment

Tried everything, the only thing that worked was running it with Oracle Java 6 instead of Oracle Java 7.

See here for Java 6 install: http://www.liberiangeek.net/2012/11/install-oracle-java-jrejdk-6-in-ubuntu-12-10-quantal-quetzal/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.