Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a toshiba satellite L770D laptop. Decided I wanted to put Ubuntu 12.04 on and duel-boot with my Windows 7. Problem is, no matter what type of keyboard I use or attempt to use, I get nothing. No typing, no response, nothing when running the LiveCD. I wouldn't care since my mouse still works, except that the ability to type is a bit of a necessity when trying to create the root user profile and logging on. Obviously, I can't use the Kernel or anything like that to attempt the fix, seeing as how I can't type at all, no matter what keyboard I try. (Tried 3, 2 USB and my internal keyboard.) So, to the question, how would I fix this? I can't get passed the initial install phase without the ability to type anything.

P.S. Nothing is wrong with any of the keyboards, seeing as how they all work perfectly on my Windows installation.

share|improve this question
    
you could try 11.10, see if that works... If so, then it is probably a kernel issue. –  steabert Aug 29 '12 at 17:53
    
Have you tried an external keyboard? –  Mitch Sep 17 '12 at 11:48

1 Answer 1

This has the fix to your problem http://neopatel.blogspot.com/2012/10/ubuntu-1204-toshiba-satellite-l875d.html you have to modify the grub and add some more lines to kernel startup as described here.

Open a terminal and enter

sudo vi /etc/default/grub

and then change the line GRUB_CMDLINE_LINUX="" to GRUB_CMDLINE_LINUX="i8042.nomux=1 i8042.reset"

then run

sudo update-grub

Also in order to do this you have to either boot in recovery mode or use an external USB keyboard.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.