Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 64 bit installed as a virtual OS in Virtualbox (the host is windows 7).

The Virtualbox data file is on a usb drive that lost connection to the PC while a session was running. Now when I try to start the Ubuntu virtual OS, I get a terminal login screen, but no GUI. When I try to login I get the message

sh: 1: cannot create /var/run/motd.new: Directory nonexistent

Any suggestions? Can I recover the system?

share|improve this question
    
Try this solution. –  mikewhatever Aug 29 '12 at 16:58
1  
Thanks, I tried it, but it seems the OS itself is damaged. –  Itamar Katz Aug 29 '12 at 18:23
    
Then I think, you should reinstall the virtual Ubuntu OS –  Anwar Shah Sep 23 '12 at 3:52

1 Answer 1

I have same error on my Ubuntu 12.04 Server and I fixed with:

rm /var/run

mkdir /var/run

reboot

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.