Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed Vmware workstation 9 on Ubuntu 12.04 & i have migrated my VM's from windows to Ubuntu 12.04 . Now i am getting openGL error & it says no 3D acceleration as shown in pic below

enter image description here

How Do I Fix It ?

share|improve this question
    
What graphics drivers do you have? What graphics card? 'twould be helpful to give a specific model. –  hexafraction Aug 29 '12 at 14:56
    
Intel HD 3000 , Nvidia Optimus .... By the way it was working fine in windows 7 . –  Qasim Aug 29 '12 at 15:08
    
Optimus/hybrid is still under heavy development. Watch launchpad.net/~hybrid-graphics-linux for developments –  hbdgaf Aug 29 '12 at 15:11
    
Did you install drivers for it? –  hexafraction Aug 29 '12 at 15:20
    
yes bumblebee is installed ... –  Qasim Aug 29 '12 at 15:22

3 Answers 3

up vote 21 down vote accepted

Add the following to the .vmx file of the VM

mks.gl.allowBlacklistedDrivers = "TRUE"

Next, install the Mesa-libtxc_dxtn1 (aka the S3 texture compression), this will probably called something be different since you are on Ubuntu and I'm using OpenSUSE 12.2.

Chances are this will crash your VM like it does to mine and only a reboot will fix it. Trying nomodeset from the boot-loader then uses the Nvidia graphics (I think - my CPU usage still rockets with glxspheres) which then WON'T crash your VM.

FYI - I have tried this but I'm afraid 3D acceleration support with Bumblebee is totally shite on Linux.

share|improve this answer
    
I was having problems with VMware Workstation 9.0.0 not working after i updated the kernel to 3.5, on ubuntu 12.04. Then i uninstalled and installed version 9.0.1, and added the above line to my WinXP VMX file, and now i get full 3D support. Actually just tested Win 8, and Aero Glass is working as well. I have Intel HD 3000 VGA by the way. –  ThiagoPonte Dec 4 '12 at 20:24
    
I have a system76 laptop with on board Intel graphics 4000 and was getting this error. Added the line gave me a warning, but it worked...just tested directX 3D support. –  HDave Apr 2 '13 at 4:35
    
+1 ..... no crashing till now ... –  Qasim Apr 14 '13 at 11:17
1  
TRUE should be in double quotes –  user204762 Oct 29 '13 at 10:22
1  
+1. Works for Intel HD3000 on kubuntu 12.04 with VMWare Player 6. The mesa library package is called "libtxc-dxtn-s2tc0" on kubuntu 12.04. –  Curtis Gedak Jul 15 at 17:30

Installing Intel Driver Fixed Vmware 3D Acceleration https://01.org/linuxgraphics/downloads

Also install VA-API (Hardware Acceleration For Intel / AMD GPUs) Is there a power saving application similar to Jupiter?

No need to do any tweaks

share|improve this answer
    
Unfortunately, Intel(R) Linux* Graphics Installer for Ubuntu 12.04 is obsolete and Intel doesn't provide download link for that release in the page anymore. I then decided to install the driver from x-updates PPA ( support.steampowered.com/… ), but the error messages persisted. I then added mks.gl.allowBlacklistedDrivers = "TRUE" to the .vmx file and it now works. :) –  Inoe Jun 11 '13 at 10:38
    
@Inoe ...There is noting extra added in intel drivers ...only VA-API ....check my answer Intel Hardware Acceleration askubuntu.com/questions/285434/… .. install it –  Qasim Jun 11 '13 at 11:14

@Xxx Xxx

I think you're wrong. If your virtual machines works without errors ("Hardware graphics acceleration is not available", "No 3D support is available from the host"), it may be because you have activated the "mks.gl.allowBlacklistedDrivers = TRUE" option in your vmx configuration file. If so, your virtual machines will explode shortly after boot. Try a game and see.

Many have tried the solution you propose and none of them works. Check out this thread: http://communities.vmware.com/message/2104179#2104179

Moreover, if you see there errors, YOU DO NOT HAVE graphics acceleration active in VMs.

Note: with Bumblebee (optirun vmware) you do not have graphics acceleration.

share|improve this answer
    
i have posted there as well ..... no aero in windows 7 .... mean no 3D accelration –  Qasim Oct 4 '12 at 0:40
    
mks.gl.allowBlacklistedDrivers = TRUE worked for me. although, before I tried this, I found the following page on the ubuntu forums, tried that, and it didn't work. Is it possible that both of these things together creates a fix? ubuntuforums.org/showthread.php?t=1531911 –  Benjamin Mar 28 '13 at 0:29
    
Actually, this does work for me (Running Altium Designer in a Windows 7 32-bit guest, on a 64-bit Ubuntu 13.04 host, with VMWare Player 6.0.0). –  Eric Anderson Sep 30 '13 at 15:31

protected by Community Nov 28 '12 at 16:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.