Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running a Sony VAIO VGN-CR410E, and recently moved it to Ubuntu from Windows 7. Both my home and work networks (which I maintain) run WPA/WPA2-PSK authentication for security.

My wireless network card (intel 4965AGN) will not connect to them unless I am in the same room (kind of defeats the purpose of wireless). The PC is 4 years old and the routers are brand new (last month or so). Had no problems with it with Win7, but Ubuntu just doesn't like the networks. As an IT manager, my laptop needs to work, so any help is appreciated.

If this is a duplicate, please let me know of what. I've spent hours searching and nothing has worked. Thanks for your help. (This is my first experience fully relying on Ubuntu). I can see the networks and attempt connection, but it fails authentication. Let me know of any code you need.

iwconfig:

lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

eth0      no wireless extensions.

modinfo iwl4965:

filename:       /lib/modules/3.2.0-29-generic-pae/kernel/drivers/net/wireless/iwlegacy/iwl4965.ko
firmware:       iwlwifi-4965-2.ucode
alias:          iwl4965
license:        GPL
author:         Copyright(c) 2003-2011 Intel Corporation <ilw@linux.intel.com>
version:        in-tree:
description:    Intel(R) Wireless WiFi 4965 driver for Linux
srcversion:     E3D7B995B1C47AE1CDDEA08
alias:          pci:v00008086d00004230sv*sd*bc*sc*i*
alias:          pci:v00008086d00004229sv*sd*bc*sc*i*
depends:        iwl-legacy,cfg80211,mac80211
intree:         Y
vermagic:       3.2.0-29-generic-pae SMP mod_unload modversions 686 
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           queues_num:number of hw queues. (int)
parm:           11n_disable:disable 11n functionality (int)
parm:           amsdu_size_8K:enable 8K amsdu size (int)
parm:           fw_restart:restart firmware in case of error (int)
share|improve this question
    
It has been covered before, but generally Intel 49xx-51xx you can try disabling hardware crypto in modprobe.d, tweaking power settings manually, and possibly some other modprobe flags. I usually go straight for disabling hardware crypto first. –  hbdgaf Aug 29 '12 at 14:56
    
Add the outputs of iwconfig, modinfo iwl4965 to the question. –  mikewhatever Aug 29 '12 at 15:31
    
Here is the question I was referring to: askubuntu.com/questions/109260/… it talks about the Intel6xxx series, but the steps tend to hold for the 4965 (it's what I have on the laptop) –  hbdgaf Aug 29 '12 at 16:13
    
aking1012: Those instructions do not work for me. I actually lost sight of my wireless card (wifi, not bluetooth) because of them. (I was able to at least fix that part). The only reason I posted a new question is that any solutions I found left my wireless completely unusable. –  marcski55 Aug 29 '12 at 20:59
    
btw: I really don't understand modprobe yet so if you recommend using it, please tell me how & why –  marcski55 Aug 30 '12 at 14:04
show 4 more comments

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.