Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a new video cam which records in h.264. In windows the videos play fine, but in linux they look interlaced. What can it be? I get the best result with VLC but they still are interlaced
edit:
here's a short video http://www.mauriziopz.eu/ricette/wp-content/uploads/2010/12/M2U00156.mpg
and here's what I see [http://www.mauriziopz.eu/ricette/wp-content/uploads/2010/12/schermata1.png
it is an nVidea

share|improve this question
    
screenshot? . . –  RolandiXor Dec 19 '10 at 22:11
    
Even better could you upload a short clip? Only needs to be a few seconds and then somebody could have a proper look at what's being produced. –  Oli Dec 19 '10 at 23:32
    
If you are using 10.10, Totem has some bug where it enables interlacing and it looks terrible. There is an option to disabled it in preferences, see if that helps. –  NightwishFan Dec 20 '10 at 1:12
    
i suspect more likely the difference in the video drivers. Is it ATI or Nvidia or ... ? –  Joshua Kersey Dec 20 '10 at 4:26
    
Video looks OK in my system (inter graphics) in Totem. I suspect a driver issue too. –  Javier Rivera Dec 20 '10 at 12:40
add comment

1 Answer

up vote 1 down vote accepted

It seems to me that the mpg file that was uploaded was indeed an interlaced mpeg2 720x576 (which is 4x3 PAL DVD resolution), and not an h.264 (mpeg4 part 10) encoded file (though h.264 it seems can support interlacing).

It looked interlaced to me too using totem (on fully updated 10.04 LTS), but running it through a deinterlacing filter using mplayer

$ mplayer -vf yadif M2U00156.mpg

MPEG-PS file format detected.
VIDEO:  MPEG2  720x576  (aspect 3)  25.000 fps  9100.0 kbps (1137.5 kbyte/s)

fixes it right up for me. Optionally, you could use ffmpeg to transcode your video using a deinterlacing filter.

Deinterlacing support was added to Totem (git master) in April 2010 (so if you're running an ubuntu with gnome older than 2.32, it looks like totem won't deinterlace for you).

So I think your options are

  1. Fiddle with the camera and see if you can't get it to save non interlaced (I suggest this as that wasn't h.264 you uploaded)
  2. Upgrade totem
  3. Transcode the video using ffmeg and filter it using a deinterlacing filter
  4. Use mplayer (or other video player) with a deinterlacing filter

references:

  1. http://www.hadess.net/2010/04/deinterlacing-now-in-totem.html
  2. http://wiki.multimedia.cx/index.php?title=MPlayer_FAQ
  3. http://www.michaeldvd.com.au/articles/palvsntsc/palvsntsc.asp
  4. http://en.wikipedia.org/wiki/H.264/MPEG-4_AVC
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.